Shadows in Photomatch Scene


#1

Hey all,

I’m using SU Pro 2016, and I’ve matched an aerial photo (screenshot from GE) to do some design studies. However, I cannot seem to get shadows to turn on in this scene, and didn’t see anything in the help forums to suggest this feature is non functional for

Matched views.


#2

Is the GE image beneath your model set to receive shadows?


#3

Hmm, never toggled that because I don’t want to project shadows onto the image. I just want the shadows to appear on the 3D objects (bridge designs and campus model).


#4

I actually don’t see that function either. Supposedly there is a context menu to select whether to cast or receive shadows, but I don’t see that option for Geo-Location terrain or matched photos.
Perhaps that’s only 2017?


#5

You may need to unlock and/or explode the GE image group before the option is available.


#6

Tried that - no dice. (see image).

All I want is the 3D objects to cast shadows…here’s a similar view which was not created with Matchphoto, and the shadows cast fine.


#7

Can you share the file? That will probably be the quickest path to a solution…


#8

Hmm…I can - have to strip out the sensitive material.

Here ya go…much appreciated


#9

Hmm, don’t see the file… try this


#10

The shadows are missing because the foreground aerial image is in the way. Note the settings in the two screen shots. I turned off the foreground image in the second one and the shadows show just fine. By the way, it has nothing to do with the background image. I just made the background image lighter in the first to make it easier to see where shadows are being cast.


Here’s an image export from the file with the foreground image turned off. I also turned off shadows on ground.


#11

Wow - cool thanks…had to dig deep for that function…what in the world is the foreground photo? Does SU recognize the matchphoto as an object, which blocks the sun? Just trying to understand the process, so I can avoid it again.


#12

I think the primary intent of the foreground image is so it can be projected onto the faces in your model as texture. In your case, you don’t seem to need the foreground image.


#13

Awesome - good to know. Thanks Dave!