Shadows are not correct


#1

I think I have uncovered a fundamental flaw with Sketchup’s shadows.
Basically I have 2 buildings on a flat site where building 1 is casting a shadow onto building 2 and the surrounding ground plane.
I want to determine the extent of building 1’s shadows on the ground plane when they are ‘reduced’ by building 2 (i.e. allowing for the vertical shadow creep up the side of building 2). So to do this, I have turned off ‘Cast Shadows’ to building 2 so that I only see the shadows generated from building 1.
What I am seeing is that building 1’s shadow is still being cast onto building 2 as expected, but the shadows on the ground plane are completely unaffected by the presence of building 2, so it is giving me incorrect results.
Am I missing something here, or is Sketchup calculating shadows on a plane-by-plane basis, rather than taking into account all objects within the shadow’s path?


Shadow of a shadow?
#2

Thus the shadow conditions at the time the draft is usually done just before and after the rendering automatically rendered shadow disappeared.
hope it is useful


#3

I can replicate the behavior.
The cube being set to not cast shadows, SU treats the cube as if it didn’t exist.
Seems a bit odd, but then so does a shadow study wherein a building in sunlight casts no shadow.
What’s the point?


#4

So the cause of this behavior may be that someone overlooked this slightly illogical combination while programming the shadow logic.


#5

Auckland Council have a requirement to show the building’s specific shadow impact on the surrounding area minus any existing buildings. Kinda strange, but unfortunately necessary.


#6

That, and SU doesn’t calculate the phases of the Moon.
I’d wager some day, some building owner will claim some proposed structure interferers with their moon glow.


#7

I suppose for such demonstrations one could paint the surrounding buildings with a translucent material.
A face bearing a translucent material won’t cast a shadow until the material opacity reaches 70%
A translucent material will not receive a shadow until opacity is 100%


Here the opacity is set to 69%


#8

Geo, thanks for the suggestion, but the point is that I need building 1’s shadow to react to building 2 as if it did exist. Then the shadow on the ground plane should not be visible on the far side of building 2.


#9

Perhaps a little sleight of hand would work.
Then again, this trick might not be so good for a complex model with several time scenes.


Here, a separate face (hidden edges) within the ground face has Receive Shadows turned off.