Issue with shadows passing through objects instead of being blocked by objects

I have a particular shadow issue that I am struggling with and not finding any answers.

To do a shadow study for a submittal, I need to show the shadows cast by just the project building on a larger model of context buildings. The context buildings cannot cast shadows, just the project building in question. I know how to manipulate the “cast shadow” and “receive shadow” options to make this happen, but the resulting shadows for some reason pass through the context buildings instead of being blocked by the context buildings like would happen in real life. I can find no way to change settings so that the shadow acts as it actually would, making it impossible to do the shadow study as needed. Am I missing something or is this just not possible? Thanks for any help.

If you turn off Receive Shadows the shadows will pass through as if the objects aren’t present. that’s the way it works.

Right, but I have receive shadows on and the shadows still pass through the object as if it isn’t present. Like this is a quick example, but the shadow from the little box shouldn’t be able to pass through the wall if it were a real shadow. I’m just running into particular requirement for a project shadow study to accurately show just the shadow impact of a new building, so I can’t give them back an image that includes shadows that wouldn’t exist. Maybe that just isn’t possible with the way the shadow controls are set up.

sha-02.skp (175.5 KB)

Thanks, I see how you did that with the split ground plane. Pretty ingenious, but unfortunately impractical for what I need because the blocks on a plane are a very simplified example of what I need to do. It is actually a more complicated street and topo site with dozens of buildings and roads and I need to visualize shadows in a variety of directions and times. If there isn’t a setting option to create the effect you show, I might just not have a good solution with sketchup to do exactly what this city wants for the submittal.

Are you trying to show incremental shadowed areas with existing shadows suppressed? In other words, when a new shadow falls partly atop an existing one, the total shadow is enlarged by whatever part falls outside the original. The goal might be to show what new areas become shadowed that were not previously, even though the presentation is not actually realistic because one can’t turn off real shadows. If that is the objective, I don’t think SketchUp can do it other than via tricks like @mihai.s showed. SketchUp’s shadow generator is purely additive, and naively relies on merging shadows where they overlap.

Yes that’s basically it and I agree that it is sounding like it is not really possible with the way the shadows generator is built unfortunately. I need exactly what mihai.s showed, but expanded to the scale of a building + multiple city blocks at multiple dates and times of day. That makes it impractical to do the ground plane trick. If I show the city a image more like the image I posted, they will get confused about the extents of the building shadows and misinterpret the impact the new building will have on the context

Thanks for the various suggestions. It is looking like my plan is photoshop to manually delete shadow areas that would otherwise be blocked by existing buildings.

https://sketchucation.com/plugin/1292-tig_shadowprojector

Not sure if this plugin from TIG would be helpful in your endeavor, but I thought I’d share it just in case. The plugin will generate outlines of the SketchUp’s shadows. You could maybe use the generated outlines as the displayed shadows, manually deleting the areas you don’t want displayed?

1 Like

question. Is the important part the shadows on adjacent buildings? Could you make all the streets and sidewalks not to receive shadows?