Casting shadows through objects

Hi folks, I’m fairly new to Sketchup so I suspect this is all my fault but…

I’ve created a model for a shed I’m planning to build along the side of my house. I’ve also created a 2-dimensional plane to show the side of my house, and turned shadows on for the model, but OFF for the “wall.”

For some reason Sketchup is casting shadows from the model through the wall to the floor plane behind.

Is it the case that a group/component that doesn’t cast a shadow also doesn’t block one? That seems a little counter-intuitive since the shadow is cast on the “wall.”

For the record I’ve also tried adding some depth to the wall so it’s not just 2D. That didn’t help.

Image attached.

I think I may have just found the answer, or something good enough for my purposes anyway.

If I turn off “Display on Ground” for shadows then I get the result I’m looking for.

More than likely the wall group or the face itself has the Shadow property set to “Don’t Cast Shadow”.

True, but that wall shadow may be distracting. So disabling “Display Shadows on Ground” is an option to get it out of the way.
There’s no option to do so in SketchUp Free to do so. You’ll need a large ground face (that doesn’t receive shadow) behind the wall to mimic that same effect.

Wow, I did not know about that function!

1 Like

Yep… It’s magic!! :grinning:

00%20PM

CD

1 Like

a small demo of those permutations. It is illogical that a shadow should continue through an object that receives a shadow as it should be blocking shadows from casting a shadow beyond itself. In ray tracing this would not happen. In the original post, while switching off shadows on ground solves the issue, IF there were to be a space between the object (shed) and the wall, there would then not be any shadows on the ground as expected as you would have disabled shadows on ground or the floor plane to avoid the object casting shadows through the other side of the wall.

shadows

In reality there may not be a ground plane to receive shadow (disabled) infront of the wall, but there would be a face (with or without texture) that receives shadow. Like in OP’s image above.

Yes, In the original post, had the wall itself been set to “cast shadows” too, it would of resembled reality.
shadow2