Trees casting shadows

Hi,
I am sort of a novice with Sketchup, and I have noticed that some objects are casting shadows and some are not. Specifically, I am creating tree groups for my simulator, and as the image shows, some groups have shadows (left), and some not (right). I am including the offending file.Tree_Mix_02.skp (2.6 MB)

I do not want to have the shadows, and did read online in this forum and other places how to undo shadows, but everything I have tried does not work. If anyone can shed a light it would be great, thanks!!

I’m not sure whether you want all shadows off, or just the trees shadows off and other shadows on for other parts of the model.

So, if you want all shadows off in the model completely, turn them off in the shadows window…

Capture

Or if you want to turn shadows off for just that set of trees for example, select the component as shown and uncheck “cast shadows” in entity info. If you look at the shadows window the button for shadows is on (depressed), but no shadows show on the trees as they are off in entity info for that component…

I hope I explain it in an understandable way, see where it gets you…

EDIT- If you don’t already, I think you’d also benefit from using scenes:https://help.sketchup.com/en/article/3000146

Hi, thanks for the reply. I must be doing something wrong, I believe that I tried both those methods. This is a screenshot of my settings, I went to edit>select all, then to entity info and made sure cast shadows was off. Then I tried it by turning shadows off (assuming that when it is greyed out is off).

but then when loading the scenery I still get the shadows:


Obviously I mus be doing something wrong? BTW, I just want the trees unshaded as the shadows flicker too much,
Thanks!!

Wait, theres something with the hierarchy, its not what I thought…

Ian, I read earlier something about that, but I still don’t know how to fix it. See, it must be that the tree group I started with had shadows selected, and when I added other tree layers it incorporated the settings of the first. But would that not be taken care of by selecting all 81 components as i did earlier/ That still did not fix it though.

Its a very oddly constructed, I selected what I thought was the top level component, but this does not contain all of the components in the model as I thought. Inside the outliner there are groups inside of components and components inside those groups!
I’ve turned off the shadows for all the top level components/groups in this example. I had to do a bit of sifting.

Try this in your full model…iantrees1.skp (2.6 MB) If this doesn’t work then you may have to go deeper into the hierarchy.

Yes it is odd, even for a newbie like me. It still casts shadows, and if you look at the tree group to the right, that one has cast shadows selected in entity info, but there are no shadows, so eventually I will really like to learn what is going on and how to deal with it when it happens.


Thanks, Bernardo.

I can’t look at your model right now but isn’t it like a chain? If one of the ‘Cast Shadow’ options is unchecked down the road in the hierarchy, the outcome for the top level is “No Shadow” casitng.

I will check the hierarchy, but will that also be true about the one on the left, I thought all were unchecked for shadows, so if one of them down the hierarchy is not unchecked, then it would cast shadows?

I still don’t see anything odd with your model as for displaying shadows. If you toggle ‘Show/Hide Shadows’ to hide, no shadows are displayed.

If however you turn on ‘Show Shadows’ all the components that have ‘cast shadows’ set in ‘Entity Info’ will display shadows.

In the ‘Shadows’ window in ‘Tray1’ play with the sliders light and dark to set shadows to an acceptable grey.

p.s. If you do have some scenes saved, be aware that they could have certain shadow settings saved as well.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.