Imported trees do not cast shadows

mac
shadows
sierra
su2017

#1

I am very new to this (about 1 month) and this is my first post. I am working on a large file, about 100 sq km of terrain with a large image projected onto it. All the buildings in the model cast shadows. When I import a tree it does not cast a shadow. When I copy and paste the same tree into a new file it works, it casts a shadow. If I go back to the large file and explode the image of the tree it casts a shadow. The terrain itself does not cast a shadow but several saved versions ago it did. Is there a setting somewhere that I have missed, or is it a problem with the file size? I am using Su 17 on a new mac with the latest OS.


#2

There is a Shadows toolbar, and a Shadows inspector panel.
On them is a toggle button to toggle shadows on/off.
(This toggle also appears on the View menu.)

In addition, each entity has two shadow attributes:

  • Casts Shadows
  • Receives Shadows

You check or uncheck these via the Entity Info inspector panel
(which most people keep open most of the time.)


#3

One reason perhaps that your tree does not cast shadows (when it is individually set to do so,) is that you’ve inserted it into a group or component that has it’s cast shadows attribute switched off. The parent obect will override the children’s shadows settings.


#4

Thank you for the quick response. The terrain and the trees are set to On Faces and On Ground in the shadow settings dialogue box. The Entity info box shows they are set to Cast and Receive shadows. The buildings on the terrain are casting shadows, just not the trees. I have placed the trees on a separate plane and they don’t work, if I copy the plane and the trees to a new doc, they work!


#5

Is it possible to share your project so forum members can look at it more closely? Screenshots are a good step; uploading the skp file gives you the most chance of a solution.

You mentioned file size in your first post; maybe you can upload to the 3D Warehouse or share a Dropbox link if the file is too big to upload here.


#6

It is 143 mb. I’m not sure if I can share the file as I am working for someone and the file is not mine. In the first image you can see the trees have no shadows and everything else does. I floated a new surface on top and place a few trees. I then copy and pasted into a new document, second image. All the same settings as far as I can tell.


#7

This is strange because my first guess was going to be "uncheck On Ground"

But I do see that the other blocks are casting shadow.

As Dan said, if shadow attributes are somehow turned off, it shouldn’t enable itself as it gets copied onto a new file.

Whilst the file size shouldn’t cause this problem, I can only think of the file itself is somehow damaged?
What if we copy the entire model and “paste in place” into a new model?


#8

Actually they are not. The shadow settings apply either model wide, or to specific scene pages if you have the scene page’s shadow settings attribute set true.

So it could be that you are viewing different shadow behavior via different scene tabs whose shadow settings differ ?


#9

Even by itself your model is so large (the largest dimension is at least 10 km) that OpenGL rendering might start to behave abnormally. And if your model has been placed at real map coordinates it might be residing hundreds of kilometers from the model origin, and this would cause all kinds of display weirdness.

Anssi


#10

I have my shadows back. I went back to the original terrain model, projected the image onto it and copy and pasted the buildings and trees ‘in place’ (from the doc that had the shadow problem) and the shadows are working properly.
Thank you everyone for your input, I think the file/terrain must have gotten damaged somehow but I’ll never know for sure, I have to move on.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.