Shadow settings Changing Suddenly in Model...does this come with imported component?


#1

I’ve been having this reoccuring issue with SketchUp models and my shadow settings. I’ll be working along and have my shadow settings as I like them, and then suddenly, they seem to change dramatically. The only thing I can think of is that perhaps an imported component brings along it’s shadow settings. But the odder thing is when I try to adjust the settings back to match what they were (including checking the time zone) the result is very different. I’m attaching 2 screen shots…one of my original model with correct time zones and the second where this has occurred. I tried to upload the SketchUp models, but I got an error message that they’re too big

This has happened repeatedly and I’m really trying to understand how to make it stop as it adds huge amounts of time to my rendering workflow. BYW, I’m using Podium to render, and I have checked with them. They think it’s a SketchUp Issue


#2

The shadow settings could change if the imported component is geo-located.


#3

The shadows are at very different times in the screenshots, have you accidentally dragged the slider? perhaps at the same time you dragged the bottles off the bench.


#4

Also, using the scroll wheel on your mouse can affect the shadow dialog sliders if the mouse focus is away from the model.


#5

If you look at the shadow settings, they are identical in each model, but the shadow is very different, so if I’m reading Box and Anssi correctly, that can’t be the issue. So DaveR, wouldn’t that geo-location be somewhat identifiable by the time zone, and so moving the time zone back to what it was initially solve the problem?

Again, my main question is "why can’t I adjust the shadow settings back to what they were (even if they’ve changed) and have them look very similar? And is there anyway to prevent this from happening initially. When you’re rendering a SketchUp model, it’s critical to keep the same light throughout the process.


#6

Look at the difference in the Time slider positions. Move the slider and see what happens.


#7

So, that’s another questions…although the sliders seem to be in different places, if you look at the intake box where you can put in an exact time, they’re identical. ( I know this is difficult to see in the images.) So, also don’t understand if the settings are identical in the boxes, the sliders don’t look identical.

Trust me, I’ve played with adjusting the sliders to make the shadows look the same, but they’re not even close no matter where I move them. It seemed to me that physically typing in the identical settings would be the most exact way of replication.


#8

I would be happy to send the 2 models to you somehow…again, couldn’t upload them here. I know SketchUp fairly well, but this is completly stumping me.


#9

Hello, you could upload them on wetransfer.com or similar service and paste the link. Compressing .skp files into zip or rar reduce their size drastically if you want to shorten the upload.

As dave said, geolocation might be the problem, and even if timezone is - 7 on both images, it doesn’t mean anything, it could have changed location to the other hemisphere!
Try to clear location on both file, for a start, and see if they match back!


#10

Yes…I see the point about the times zones. How do I clear the location?


#11

window > model info > geo-location > clear location


#12

Nice to know that…however, neither model was geo-located when I checked.

This is the link to the 2 files…the earlier one (the one whose name ends in .2) is the original with the shadow where I wanted it. The second one (ending in .3) is after the shadow shifted.

Thanks to anyone who can help me figure this out!

Diane


#13

No Links.


#14

Sorry…I was multi-tasking…here is the link. Thanks for being on top of it!


#15

Hello,
I never knew about it but when you import a component that is geolocated it will change your shadow settings indeed.

If you want to avoid this, you have to geolocate your model as well, it will lock the shadow settings even if you import a geolocated model !

Or, because it seems it only happens when you “load this directly in your sketchup model”, you have to save the components you get from the 3D warehouse to your HD first, then import.


#16

I didn’t realize this either - I’m declaring it a bug in SketchUp. When would you ever want an imported model to change this in your main model? At the least SketchUp should warn or ask you what you want to do.


#17

I agree !


#18

Edit - Eh just assume any ShadowInfo could be changed
.

These are the specific ShadowInfo values that were changed in my experiment:

City
Dark
Latitude
Light
Longitude
SunDirection
SunRise
SunRise_time_t
SunSet
SunSet_time_t
TZOffset
UseSunForAllShading

#19

Thanks all…does seem to be something that SketchUp should look into and improve upon. Paul, in the meantime, I’m going to follow your advice and geolocate each model. Thank you for that solution. If anyone else has a different way of handling the problem, I’d love to hear it.

One solution that works sometime (but not always…like in this case) is to reimport a version of the original model (with correct shadow settings) into the later version (with incorrect shadow settings). Sometimes this will get the shadow settings to flip back, sometimes not. I would be curious as to why.


#20

I don’t think there is a way other than having to relocate manually or importing another geolocated component… I ran a few tests ,if you geolocate the same file on different positions, they will keep their own shadow settings even after you clear location ; until you set a new one.
perhaps by chance you imported another component from 3D warehouse that had a position close to the default one but I don’t think importing an earlier version would fix anything.