About shadows in Sketchup

Good afternoon,
In this 2023 version and also in the previous one, the time we set for the shadows defaults to an hour, day and month and even when I change it, it returns again and again to the same date. This is very boring. How can I fix this problem?

Do you have a scene you are clicking on when it reverts to the previous time and date? If so, you need to update the scene after you change the shadow settings.

Thank you :slight_smile:

I think this solves the problem