Selection Toys script not working osx su2015

Im trying to get Selection Toys to work on SU2015 on OSX 10.11.6
Ive tried a couple models and each time i try nothing happens. I select a face of edge or anything from the rightclick menu nothing happens. There is no error log in the Ruby window so i can t post a log here.

Here’s a very simple test cube. When i select a face or edge and try to use the tools nothing happens

#thomthom #ThomasT.

Exactly what menu item are you using? Which of the many functions are you trying to use? Most of them filter the existing selection - while some makes a new selection. Need to know which ones you use and what your initial selection is.

(btw, to mention someone on the forum use @ - the # is for headlines)

k thanks, im new here…

I tried select edges, faces, components, groups none of them work. At least i think. I need to select something first in order to get it working, right? That’s what i thought its for…

Neither the right click or the tool pallet does do what i think its supposed to do

Exactly what is the title of the menu item?

Notice it says “Select Only” for the parent menu of the “Edges” item I selected in that screenshot. It means it will take the existing selection and reduce it to only the edges.

Can you describe specifically how you use it and what result you expect?
Maybe show some screenshots?

thanks, i feel stupid!!!

I tried it by selecting one thing at a time thinking it would select simular objects. It works indeed i was doing it wrong all the time.

No worries. The way I always use it is that I make rough large selections, then filter them down. That gave me more control than making it select everything.

Maybe the menu item could be renamed “Filter Selection to” or something similar?

Thats indeed great idea! Says a bit more about its function