Selection Tool process is slow, unbearably slow

update
windows10
kb4013429
kb4013418
kb4015438

#162

First test :
If I stop the process during “selection” : I have this call stack : (I try two time and I have the same call stack)
ntdll.dll!00007ffb86545434()
KernelBase.dll!00007ffb82c4988f()
ig7icd64.dll!00007ffb58874a90()
ig7icd64.dll!00007ffb58466b14()
SketchUp.exe!00007ff6ab44d252()
SketchUp.exe!00007ff6ab0c8050()
SketchUp.exe!00007ff6aaebb6f2()
SketchUp.exe!00007ff6aaaa268e()
mfc140u.dll!00007ffb600101ba()
mfc140u.dll!00007ffb6000fcce()
mfc140u.dll!00007ffb6000cf6c()
mfc140u.dll!00007ffb6000d344()
mfc140u.dll!00007ffb5fe9d471()
user32.dll!00007ffb84a4bc50()
user32.dll!00007ffb84a4b80b()
opengl32.dll!00007ffb6b0c911e()
user32.dll!00007ffb84a4bc50()
user32.dll!00007ffb84a4b5cf()
mfc140u.dll!00007ffb5fff4442()

mfc140u.dll!00007ffb5fff4e83()
SketchUp.exe!00007ff6aaa27de2()
mfc140u.dll!00007ffb6002af97()
SketchUp.exe!00007ff6ab2eba9a()
kernel32.dll!00007ffb84c02774()
ntdll.dll!00007ffb86510d61()

During a Idle time : this call stack appear :
win32u.dll!00007ffb829c1144()
user32.dll!00007ffb84a62c66()
mfc140u.dll!00007ffb5fff4417()

mfc140u.dll!00007ffb5fff4e83()
SketchUp.exe!00007ff6aaa27de2()
mfc140u.dll!00007ffb6002af97()
SketchUp.exe!00007ff6ab2eba9a()
kernel32.dll!00007ffb84c02774()
ntdll.dll!00007ffb86510d61()


#163

Another IMPORTANT information :

I restart my computer … I wait enought (2 or 3 minutes) to have the “night mode screen”

SU work fines !!!

I think if you load SU after boot too soon … SU works wrong !!! It seems strange but it’s true !!!

It late today, I go to sleep … but I will be able test my scenario another time today …

PS : no, I try 2 another time without waiting, and NOW, SU works fine …

I am sorry … I have not a good scenario …


#164

In some cases , depending how you upgraded to W10 , the updates are automatic, but try and change:
Go to start, select control panel, select widows update, select change and see if you have option at top to change.
On the control panel you can also select administrative tools and you can select items and can even see some that run updates that may even occur in the middle of night.
At the present time my machine is running more that 4000 processes.


#165

Dear Tibaud60

With respect I think you are maybe trying too hard with this problem and maybe should go back and just remove some of the latest windows updates until you get to a point where SU works consistently . I am sure it is a change to windows 10 that has upset some graphic cards from working correctly. Once you can nail which update it is that causes the problem then it is up to the sketchup team or MS to resolve the issue in depth, hopefully they are working on it.thanks

best regards Flyingstoo


#166

@@flyingstoo
Dear you :slight_smile:
For too night, with no change, First boot >> slow, Second boot >> Fast, third boot >> fast !! WITH NO change on my computer
Moreover, My windows have no update since last night !
I hope my informations could help SU developper Team to find the defect …


#167

Somente para corroborar com as informações de que o KB4019472 está causando travamento na ferramenta “selecionar”. Vejam bem, não é lentidão no sistema, outras ferramentas funcionam normalmente sem lentidão, apenas quando utilizamos o selecionar o sistema trava e demora uns 7 segundos para liberar o mouse e se clicarmos de novo, mais 7 segundos, inviabilizando o uso.
Desinstalei o KB4019472 e funcionou normalmente, sem nenhuma outra alteração.
Porém sei que o windows irá instalá-la novamente, já que não há como desabilitar.


#168

Only to corroborate with the information that KB4019472 is causing locking in the “select” tool. Look, it is not slow in the system, other tools normally work without slow, only when we use the select the system hangs and it takes about 7 seconds to release the mouse and if we click again, another 7 seconds, making it unusable.
I uninstalled KB4019472 and it worked fine, with no other changes.
However I know that windows will install it again, since there is no way to disable it.

*by google tradutor


#169

I can also confirm uninstalling KB4019472 returns my SU to normal operation, and I believe I can keep my PC in this state until I decide to restart Win 10 Updates again (hopefully days/weeks away?).

I am using Samsung Notebook Win 10, Version 1607 Build 14393.0
With Intel HD 4000 graphics Driver: 17-8-2015 Version:10.18.10.4276
Sketchup: Version 2017 (latest)

My procedure:
Control Panel->Administrative Tools->Services->Windows Update
I changed setting to “Disabled” and for 3 days now Windows has NOT updated and SU is running as normal with instant Select Tool

The following article explains my procedure the consequences and obligation I now have.

Hope this helps someone else.

It seems to me ONLY Microsoft can fix this problem, advised in detail by SU Engineers, by issuing a later version Update to correct whatever happened inside KB4019472.

I don’t want to have these updates turned off for very long due to other critical security risks!


#170

This seems to be a very persistent issue.
Does anyone know if SU has reported it to Microsoft or do we have to just take pot-luck on when Microsoft will become aware of it and correct it (hopefully for good).


Sketchup running slow lagging
#171

By this time Microsoft certainly knows about this. SketchUp is not the only application affected, similar discussions go on in other 3D software forums too. I think @DanRathbun posted a link to Microsoft hotfixes supposedly fixing the issue. Others have referred to updating the graphics driver helping.


#172

Another solution I discovered today: uninstall adobe flash player!


#173

Try this fix: Go to Windows->Preference->OpenGL and disable “Use Hardware Acceleration”. Hope this help


#174

@SecondLife, That’s not an option in SketchUp 2017.


#175

Thanks for the tip to all of you! I also fixed the problem by downgrading my display adapter driver (Intel HD Graphics 4000) to version 15.33.38.64.4252 (reported by Device Manager as version 10.18.10.4252).
I previously had version 10.18.10.4358. Windows 10 1607, 64 bit.


#176

You are right. That option has been removed by Sketchup 2017. It’s a work around for previous Sketchup version but a rther poor one since it will slow down Sketchup significantly but I’ve got works to do. I’ve also tried to roll back my HD4000 driver to version 15.33.38.64.4252 as suggested by arwe below but that did not work for me. I am still on Sketchup 2016 since all my works are 2016. I am extremely leery of migrating all my files and typically wait for a while before doing so. It is extremely frustrating to deal with this issue. It looks like Microsoft screwed up big with some unknown recent graphics card update since my computer display is now unstable (sometimes the display refreshed entirely by itself). This is no way Sketchup’s problem. I hope Microsoft own up to the issue and fix it for us soon.


#177
  • OS version/build: Windows 10 Pro, Version 1607, Build 14393.0
  • Graphics card make/model: Intel® HD Graphics 4000
  • Graphics card driver version/build: 10.18.10.4358 (downgraded to this from the latest version but it didn’t help)

I don’t know if this has been pointed out before, but selecting stuff from the Outliner works just fine. Even when clicking on the model doesn’t.

The only thing that consistently solves the problem for me is uninstaling every Windows Update since mid March. Now I have disabled automatic updates.


#178

OK. I had pretty much all the problems described above, and thought it would be unwise and unsafe to start uninstalling Windows Updates.
In the end, I found out what the problem was in my case.
Dell Precision Workstation, with Intel Graphics Card and also NVIDIA High performance graphics card.
I downloaded the Sketch Up Check Up tool here:
http://dl.trimble.com/sketchup/install-checkup.exe
It recognised that when I installed the new SketchUp 2017, my NVIDIA controller stopped being activated, and it was trying to run the SU graphics through the ow grade built in Intel graphics card.
I opened the NVIDIA control panel and activated a profile or SketchUp, and voila!
All the most recent Windows Updates are installed, and SketchUp Pro 2017 runs super fast.
I hope this helps others.

The reason for this is that in the Windows Update there is a tool that lets the system assign a graphics card depending on the programme, and in my case, it was choosing the wrong one.


#179

Hi, I got that too but found a solution. See my post below.


#180

I contacted Microsoft this evening and told them about the problem and after a few back and forths with a technician they gave me an update to address this terrible update. Please take note that this update took me a long time to complete. Also I am not sure 100% it was the fix or running the checkup install link provided by pinyol. By reason of deduction Iam going to say it was the checkup install that did the trick, but I have included the link anyhow. I hope it helps.
http://download.windowsupdate.com/d/msdownload/update/software/updt/2017/05/windows10.0-kb4023680-x64_de5502ce899738bedd5eb20f10cfe67ea26ff5b6.msu


#181

the automatic updating of (only) hardware drivers can be disabled selectively by the free O&O ShutUp10 tool: