Selection Tool process is slow, unbearably slow



another time, Selection tools is slow … and nothing is updated on my computer, since 13th may (4 days ago) …


and I Reinstall the driver, and after reboot, it work fine … the last time, I Use the 10.

the last time, SU for fine with driver …

I think the bug is not in the driver, I think the bug is in a parameter of the driver, ant this parameter is reset each time I install a driver, and this (or these) paramater(s) is change by Window somtine …

an idea ?


Sorry, @DanRathbun, but can you clarify what you’re saying by “not supported”? I use SketchUp Pro 2015 on Windows 10 with no issues. I’m running Creators Update, in fact, and all is well.


If folks are still experiencing the slow selection problem could you please reply to this post with the following info:

  • OS version/build
  • Graphics card make/model
  • Graphics card driver version/build

I’ve reproduced the issue in-house, but only on a very specific configuration (Win 10 1607, Intel HD Graphics 620 / Nvidia GeFoce GTX 950M).

Mark Chandler


@MobelDesign, SU15 uses an older version of OpenGL. What Dan showed is that your integrated graphics driver will not be updated to add the version of OpenGL SU17 now requires. You could try SU16.


SketchUp 2015 (initial release M0) was released November 3rd, 2014.
Microsoft had on September 30, 2014 only just announced that Windows 10 would be the successor to Windows 8.1. So there was no way that the initial release of SketchUp 2015 could be tested with Windows 10.

Even by the time of the last maintenance release (M3) of SketchUp 2015, on February 5, 2015, there really was not time to test under any beta version of Windows 10, even if any had been released. (Windows 10 was not publicly released until July 2015.)

By February of each year, the team is releasing the last MR for the current SketchUp version, and already planning the work for next year’s release (which was to be SketchUp 2016, in this case.)

Look at the SketchUp Application Release Notes page, under the initial release of SketchUp 2016, and you will see this section:

Support for El Capitan and Windows 10

Our QA team has smashed and banged on these new operating systems enough to say that SketchUp 2016 is fully compatible with Apple’s El Capitan and Microsoft’s Windows 10.

This is the first time in all of the releases that support for Microsoft Windows 10 is declared by the SketchUp Development Team.

Well, this is good, but when you do find one, you just know that the answer (from SketchUp support) will be to upgrade to a newer version. (It may be that you just have not run into any of the known issues, or subsequent Windows updates may have fixed old issues.)


this morning (cf previous post), SU don’t work
I reinstall, I Reboot, I Work fine, I shutdown my computer
this night, I restart my computer >> SU don’t work again !!!

My SU version is 17.2.2555
My Processor is i7 3770K 3.5 Ghz
I have no graphic card, only one on UC … HD4000
Version GL is 4.0 (visible on window preference in SU)
Driver is still
Format Pixel is DBL RGBA 8-8-8-8 Depth:24 Stencil:8 MSAA:0 FF:0

the graphic card driver is not the problem … but install the driver do something to solve the problem during a short duration …

I have no idea to solve this …

could you help me ?


Thanks for clear answer. It all makes sense now.

The only excuse I can think of :wink: is that it was late at night and when I read “SketchUp 2015 is not supported under Windows 10” it made me think that it was not supposed to work at all, when in reality it works fine. I understand now that you meant that it is not supported in terms of maintenance updates.


Having read through this thread I still see no solution.

The problem is that Windows update KB4019472 causes a problem with Intel HD4000 graphics cards( and probably others) which results in sketchup 2017 selection controls running very slow ( approx 7 secs before a response is seen)

If I take out the update and reboot then sketchup 2017 works fine but unfortunately windows 10 will always eventually replace KB4019472 again.

Has anyone got a technical solution from Microsoft?


on my computer, I have not KB4019472 … but selection tools is slow …


This maybe because you have windows 10 1703 version , mine is 1607 version.

However I am not sure if update KB4019472 is common to both. You could try removing any updates that have come in in the last month and see if SU works after removal. remember to restart the computer after removal before checking SU.

I have proven beyond doubt that there is a link between installation of KB4019472 and the slowing down of sketchup make 2017. I have temporarily stopped the windows update service until this is resolved.


@flyingstoo, Please provide the requested details by Mark in Selection Tool process is slow, unbearably slow so that we can try to reproduce the issue at our end.

Also, have you tried updating the Intel 4000 graphics card drivers from as shown in to see if it helps?


@thibaud60, Please provide the requested details by Mark in Selection Tool process is slow, unbearably slow so that we can try to reproduce the issue at our end.


How did you get to W10?
Strange question but if upgraded to 10 during the 2015 frame period( when it was free) there are some license agreements you have made with MS, do you remember what they are? That upgrade was good for one year and that limit will soon be here.
There are lots of chatter on the windows 10 forum and it associated with graphics driver problems. Conesus seems to be to get the driver from machines manufacture because they may well have changed the INTEL driver to fit their particular design. As aside, a search of the MS dump crash analysis web site they state they have more issues with .dlls ( vendor graphics drivers than any other.)
Depending on the license you have you are probably well past the time MS allowed you to roll back to the old windows version.)


for yogesh
my system details are
windows 10 ver 1607
os build 14393 1198
X64 bit processor
display is
Intel Grapgics HD4000

hope this helps


Not exactly sure if my integrated graphics card is the HD4000
all it shows is intel® HD Graphics


My system details are:
Windows 10 Pro 64 bit version 1703 OS Build 15063.296 - all Windows updates up to date as of now (May 18/17).
Display is Intel HD Graphics 4000 version
I manually updated my Intel graphics driver to version but it made no difference (the selection tool is still slow).
SketchUp Make version 17.2.2555 64-bit.


I’ve been able to reproduce the problem on an Acer laptop that’s equipped with Intel HD 620 and Nvidia GeForce GTX 950M graphics cards. The system is running Win 10 1607 (14393.1198) with the following updates:


The Intel driver is I tried updating it to 4664 directly via the Intel website, but it wouldn’t install. The Acer website lists an even older version of the (Intel) driver, and the Windows device manager reports that there are no updates available (for the Intel card).

When I updated the Nvidia driver to 382.05 (from 376.54) the slowness stopped. I tested SketchUp 2016 and 2017 with both the Intel and Nvidia cards and didn’t experience any lag when drawing or selecting.


Actually, I am happy with windows 10. It’s just the latest upgrade that I had problems with. When I rolled back to the earlier version of windows 10 it fixed the problem.



@yogesh :

Hello, this night, SU works fine … I do nothing else than start my computer this night, 5 minutes ago …

you can search Thibaud60 in this thread to read my history

I use SU 17.2.2555.0, 09/02/2017 - 14:34, Make version.

I am just an “amateur” on SU … but I am also a developper, so I can help you to do any tests if necessary (like a memory dump or something else, I Have Visual Studio on my computer)

Today, it would be difficult … SU Works fine …

Helps these informations can help you and anothers users …

Bests regards.

PS : I just reboot … It is, now, another time slow !!!
the difference beetween :
the firt time, today, I start my computer and wait 10 minutes before I use it, and “night mode screen” (new fonctionnality of Windows 10) was enabled
the second time, I do not wait before launch SU, and “Night mode screen” is not enabled …

I am going to test another boot now (and wait before Use SU) …

My graphic card (from “Information systeme”)

I have no graphic card, except one “in” my processor …

Nom Intel® HD Graphics 4000
Type de carte Intel® HD Graphics Family, compatible Intel Corporation
Description de la carte Intel® HD Graphics 4000
Mémoire vive sur la carte (1 879 048 192) octets
Pilotes installés igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
Version du pilote
Fichier INF oem39.inf (section iIVBD_w10)
Plans de couleurs Non disponible
Entrées de table des couleurs 4294967296
Résolution 1280 x 1024 x 75 hertz
Bits/pixel 32
Adresse mémoire 0xF7400000-0xF77FFFFF
Adresse mémoire 0xE0000000-0xEFFFFFFF
Port d’E/S 0x0000F000-0x0000F03F
Canal IRQ IRQ 4294967289
Port d’E/S 0x000003B0-0x000003BB
Port d’E/S 0x000003C0-0x000003DF
Adresse mémoire 0xA0000-0xBFFFF
Pilote c:\windows\system32\drivers\igdkmd64.sys (, 3,62 Mo (3 793 872 octets), 03/05/2016 23:30)

Nom du système d’exploitation Microsoft Windows 10 Famille
Version 10.0.15063 Numéro 15063
Type PC à base de x64
Référence (SKU) du système SKU
Processeur Intel® Core™ i7-3770K CPU @ 3.50GHz, 3501 MHz, 4 cœur(s), 8 processeur(s) logique(s)
Version du BIOS/Date American Megatrends Inc. 2104, 13/08/2013
Version SMBIOS 2.7
Version du contrôleur embarqué 255.255
Fabricant de la carte de base ASUSTeK COMPUTER INC.