Selection Tool process is slow, unbearably slow



I see there is still no real solution to the slow running of SU for people who have Intel HD integrated graphics cards and who are affected by MS update KB4019472 .

My Intel card driver is up to date and rolling back to older drivers is not something that I believe will fix this problem.
The only way of running SU is to remove KB4019472 (or its equivalent) and then prevent further automatic updates by stopping the wuauserv service.

The solutions given by people with other types of graphic cards is fine for them but I only have one perfectly adequate integrated card and don’t want to start chasing this problem by installing yet more hardware.

So who is the going to win the tech prize of the month and tell us why /what is in the KB4019472 update that causes this problem?



Not a pleasant surprise finding out during a presentation at a client that MS broke it again…

Fixed it again by de-installing the gfx drivers, reboot and re-install the 153343.4425 drivers from Intel.

I5-3320M, 8Gb, HD4000, 64 bit Win10 Pro,


Solved for me by:

NVIDIA control panel > Manage 3d settings > Global settings > Preferred graphics processor = High Performance NVIDIA processor.


You shouldn’t have needed to go through the Global settings menu. Going the next tab over, to the program specific graphics setting to just fine tune the settings for SU, should have been good enough.


Well the above comment suggested I should check my own “INTEL HD Graphics 4000 Graphics Control Panel” which I didn’t even know existed until just now!!!

I started it with Windows Start button then typed “INTEL” and there was the application!

It has a 3D panel/button with LOTS of options … so many I am scared to touch anything for fear of unintended consequences.

I still have Windows Updates turned off after 2 weeks now.

Can anyone suggest what the INTEL 3D settings should be to solve/correct the current Slow Select Tool SU

issue please?



Global Settings sets your graphics options to be used for everything. Choosing the Nvidia card to always be used for everything will dramatically spike power usage. That’s not an issue with a desktop setup (it’s default), but it may become an issue for laptop users and how fast the battery drains when the computer isn’t plugged in.

To better manage power consumption on laptops, go to the Program Settings tab, select SU, and choose the Nvidia card for that program. Leave the global setting set to the integrated Intel graphics.


This started AGAIN today (after computer restart).
Windoze 10 Pro 10.0.15063
Intel HD Graphics 4000, Version: 4.0.0 - Build
SketchUp Make. Version 17.2.2555 64-bit


Nothing helps. It’s getting more and more frustrating. I’ve tried uninstalling updates, reinstalling graphics card drivers… Does anybody know if this problem bothers only Intel HD4000 users? Does SketchUp will make a fix for this?
For about 2 months there is no change :confused:

EDIT: I finally found correct display driver: Intel 153343.4425 driver and I also turned off automatic driver updates ( ), now seletion tool works perfect Thanks


Here’s the same information presented differently:

Warning! Since both of these rely on changes using the Local Group Policy Editor, I don’t think it will be available unless you’re running the Professional version of Windows 7 and later!

I haven’t done this myself (yet), but I have both of these sites - and this thread - bookmarked in case this problem rears it’s ugly head.


On my PC, SU17, Win10 with creaters uptdate i solved the problem by changing the settings in NVIDIA 3D Settings for Sketchup to prefers grafikprozessor to NVIDIA HighPerformence Pozessor. From this time it works fine.

04jun2017 - Winnner! You saved my ■■■■, mate.

HP DV7T-7000 laptop (quad i7 with 12gig RAM)
2x Dell 2407 monitors plus internal display (total 3 screens)
Win10x64pro 1703 build - Latest as of 04jun2017
Intel HD Graphics 4000 with driver downloaded off Intel site (153343.4425)
Nvidia 630m with driver downloaded off Nvidia site (382.33)
SIIG usb3 to HDMI adapter with ‘magic Control Technology Corp’ driver 1.4.1702.516 dated 16may2017


@sketch3d_de recommended O&O ShutUp 10 to help control hyperactive Win10 updating. Prior to Win10, Windows updates already included an option to monitor and at least look over all recommended and optional updates before download and install.


I posted differents messages on this thread for one month now, SU developer team could see before to have some informations about my configuration.
Lot of message explain it is a problem with graphic card’s driver.
For my part, even if the graphic card’s driver have common points with our problem, my computer works fine some times, and works slow another time. this depends of boot sequence. If SU works Fine one time in a sequence of my computer, It works fine all the time before I Reboot
And If SU works slow, It work slow each time before I Reboot.
The call stack, I posted on this thread Before, is the same each time the slow action is occurs. and a call of WaitForSingleObjectEx Windows API return each time a Timeout result. (I change the duration of this time out period and If I put 10000 ms I wait 10000 ms. with a stop point in Debugger of Visual Studio and change processor register …)
I can not find another information to help … I don’t know if my post is read by SU Developper Team …

my conclusion now : Something during selection process need to lock sommething else to communicate beetween threads, main Thread UI and another thread … and this lock is probably a dead lock … and the time out in WaitForSingleObject is occurs each time … (4264 ms or something like this, I have not the exact duration now … Because my computer decided to worked fine today :slight_smile: ) an it is why we need wait 4/5/6 secondes between each selection …

Why ??? I don’t know … and my only one work arround to solve this problem is to reboot one time, two time, more to reach a good sequence for SU works fine

@yogesh : did you reproduce my scenario ?!


(excuse my english ; )
I run SU on Windows 10, with Intel HD Graphics 4000.
SU suddenly became slow. None of the KB mentioned above to be found on my computer
I tried uninstalling/installing graphics pilot and SU, no result.
The final solution was:
going to the Intel HD Graphics settings/ 3D settings/ set on “performance”.

I hope this works on others !

Not a Microsoft problem, not Asus, not SU, just Intel.
Why sell a product and not set it at its best (I know the answer, but they could tell !)


I’ve acidentaly tried something and it just worked for me!

Try to import an autocad DWG to your project, after import, you can delete the DWG, someway it just fixes this Bug.

After import, open your document in that window and Enjoy!


Hi,Nothing from above helped me with my sketchup 2016 and 2017.
I have IntelHD Graphics card integrated with Celeron J1900 processor.this is just a little barebone computer from Gigabyte.I had the same problem with the Select tool.Sketchup freeze for a while when tried to select something.
I’ve tried this and works well.
Go to Sketchup/Window/Preferences, then select OpenGL and untick ‘Use hardware acceleration’.
Restart Sketchup and enjoy the Select tool.
Good luck.


Yes. Unticking Use Hardware Acceleration is an option for older versions of SketchUp. It makes the CPU do the rendering instead of your inadequate graphics card. With SketchUp 2017, CPU rendering is not an option and the GPU must be up to the job.


@arts70, Do you have the latest available graphics driver installed ?


Yes.I’ve tried new and old ones.


I know this is not the best way to fix it but I am able to use the Select tool now. Sketchup worked perfect on my little barbone computer before some windows update was done so, this is the best way for me now.I can’t change my graphics card.
Driver Provider:Intel Corporation
Driver date:21/12/2015
Driver version: