Selection Tool process is slow, unbearably slow



I was mainly pointing out that disabling Hardware Acceleration is not an option for SU2017.

As long as you’ve got things working for your situation, keep going that way.


jemtz… If you have had no luck with rolling back updates to get you’r KSP Studio to work try going to your update history & check to see if you don;t have A recent Microsoft Visual C++… updates in duplicate, that’s in series & OS. Uninstall the most recent of the 2. but make sure they are the same for both operation system & KB Number & not size?. usually they only have A KB Number & nothing else in the uninstall updates dialog, for Me it was A (KB3150513)in duplicate. than goto search for updates & update again, reboot & try your studio & any video streaming you can.I have A Win10 1607 HP 64bit Integrated Desktop, it;s Not much? & I don’t Auto-Up.The graphics are terrible, so I do my own updates. Check & see or just re update & reboot (you can always remove any thing. & by the way only update your security from windows defender & what ever else you use after any update. worked well for me.


Well, it’s not my preferred solution since I’ve already created files in SU Make 2017 but I still have SU Make 2016 on this computer. Sure enough, if I launch SU 2016 and uncheck “Use hardware acceleration” under OpenGL, I am able to successfully select items in my older files. I toggled it back and forth and the selection issue came and went as suggested. I guess I’ll just have to go back to my 2016 SU until a Microsoft update comes along that fixes SU 2017. Thank you DaveR and arts70! I feel like I can get back to some serious designing!


@Oaktrimmer47, disabling hardware acceleration in SU16 means the CPU is doing everything - the graphics card/driver is not involved. In other words, your graphics chipset and its driver isn’t up to the task of being used in SU16. SU17 has higher system requirements. You may not want to hold your breath expecting MS updates to ‘fix’ things.

Computers don’t last forever. The issues you encountered would be useful to guide when it’s time to upgrade your hardware at some point in the future…


Hi all, my SU was working fine until I opened Artlantis 6, then both programs started lagging, I reset my windows 10 and reintstalled the programs, SU was working fine until I opened artlantis again then both programs started lagging, very slow, not responding. I uninstalled both programs and reinstalled SU but the problem persists.
Meanwhile 3D Max, Rhino and PSD are working perfectly.

Any suggestion?


Mark, here’s the info:

  • OS version/build: Windows 10 Home 64-bit (10.0, Build 14393)
  • Graphics card make/model: Intel HD Graphics 4000
  • Graphics card driver version/build:

(I got the above info by clicking Win + R, then typing “dxdiag”. The OS was on the System tab, the Graphics card info was on the Display tab.)

If I uninstall KB4019472, the Select tool works fine.

Before uninstalling the Windows Security Update above, I updated my Grpahics Card to the newest version but that hadn’t helped. I will try some graphics card updates/uninstalls again now, using some of what I read elsewhere on this thread.

UPDATED: weird. I just tried SU this morning, and it works just fine. No lag on the selection tool. And the Windows update IS installed again…


Thanks, @katerenn

I’ll investigate further. KB4019472 seems to common culprit, but it hasn’t always been the root of the problem with our in-house systems.


Have you asked in the ArtLantis forum or created a help ticket at ArtLantis? It sounds like ArtLantis is the culprit. Isn’t restarting your computer (or turning it off and back on again) enough, do you really have to reinstall?


@jody, this thread should not close in 3 days.


This topic should not close because the issue is not solved yet! The only work-arounds applicable to me involve uninstalling Windows updates, which I don’t regard as a solution.


Thanks for calling attention. I’ve fixed that.


Hello, SU was working fine this morning until I reboot the computer. Then the selection tool becomes unbearably slow. Many are talking about backing from the last windows update. Is this the solution and how you do it actually?




@jody :
hello, new element for my part, I received this update
2017-06 Mise à jour cumulative pour Windows 10 Version 1703 pour les systèmes x64 (KB4022725)

and SU work fine One time after the reboot yesterday, and not ok this morning with a new reboot

the problem persists … you wiil be able to saw my last posts in this thread to know my history, Driver number, computer description, call stack for developper Team, etc, etc to reproduce and help to find the bug …

Best regards


Still frustrated by the slow selection tool. None of the options suggested so far seem to be applicable to my situation, however I do seem to have discovered a work around which will probably be OK for ‘amateurs’ like myself, although the professionals won’t like it, I suspect.

To begin at the beginning, I have a 2year old 64bit Lenovo Ideacentre, with on-board Intel HD Graphics ( no other designation number). SU Checkup tells me my system is fine for SU2017 but I have the unbearable lag on selection tool. My Windows 10 system updated to 1706 on 6th June and I installed SU for the first time a couple of days later. When I check Windows Update, none of the Updates mentioned in this thread are shown as having been installed and I suspect that the 1706 upgrade incorporated them all as part of the consolidated build. Since it took 2 hours for the upgrade to install and so far I’ve found no other problems with it, rolling back to the 1607 version is not a viable option to me, especially since I would presumably then have the problem of the culprit update continually trying to re-install itself.

I have seen various suggestions that using SU 2016 solves the problem, but that isn’t strictly true, in my case at least. I have installed SU 2016Make, 64bit version, to see what happens, and found the lag is still there. I then went even further back and installed SU 2015Make, 64bit version, but again the lag is still there.
I then had a flash of inspiration, removed the SU 2016 64Bit and installed SU 2016 32Bit instead and, lo and behold, it seems to be fine!
So whatever the underlying problem is, it appears to be affecting a difference between 32 and 64 Bit versions of SketchUp.

As I say, this is unlikely to be satisfactory for the professionals, but it seems to work for us lesser mortals who don’t necessarily need the finest bells and whistles…


It is likely more a difference between OpenGL library bitness. We have seen this in the past.
I believe the issue lies within the Intel graphics driver code, and Microsoft’s recent updates have broken it.


@philipy, did you try updating your graphic driver? First go to your computer manufacturer but some people can download updates directly from Intel. The work-around of dropping down to 32-bit was usually associated with computers with AMD graphic cards. Which as Dan mentioned, had a notable difference in OpenGL driver support between 64- and 32-bit programs running under 64-bit Win10.


Yes, I should have mentioned that I got the latest graphics driver direct from Intel before dropping down to SU 2016/2015/2016-32bit.


Any plugins/extensions installed?


I installed “Solid Inspector2” in SU2017 64bit, but not in the other versions.


I just erased the Security update for Adobe flash player. Reboot and Sketch up is back to normal .