Select Rectangle Issue - SketchUp Make 2017 on MacOS Mojave - 10.14.5

When drawing a select rectangle on Make 2017 on MacOS Mojave, dragging left to right is a solid normal rectangle. When dragging right to left, MULTIPLE rectangles are drawn, similar to “zoomin rects” from the past. This is on a new MacBookPro 2019 running Mojave 10.14.5.

See the below screenshot …

There are two graphics cards – I am not sure which one is being used by SketchUp, nor am I sure if I can update drivers.

  • Built-in - Intel UHD Graphics 630 1536 MB
  • PCIe - Radeon Pro 555X - 4Gb

Thanks for any help,
Jon

Unfortunately, SketchUp 2017 was released before Mojave was, and doesn’t officially support Mojave.
It supported Yosemite, El Capiton, Sierra, (and later with maintenance release 3, also High Sierra.)

Since Make has been discontinued, there will not be any updates to it.

The M1 update for SketchUp Pro 2018 (ver 18.1.1180) was specific for Mac and OSX Mojave fixes.


The Details subdialog of the Preferences > OpenGL dialog panel should indicate which driver SketchUp is using.

The Radeon software should allow you to indicate which GPU you want to run certain applications.


You might try switching off Fast Feedback (if the Mac edition has this option) in the Preferences > OpenGL dialog.

Thanks Dan, good to know this information. I still have my old laptop, which is running the same software versions (SketchUp and Mojave) which hasn’t had any issues. And to Trimble’s credit, I’ve been using Mojave since it came out and haven’t had any issues. I think it is the graphics card now, see below on your other comment.

The new laptop is using the Radeon Pro 555X in the OpenGL dialog box. I checked the old one, and it is using an NVIDIA GeForce GT 750M with 2GB. Does anyone know if there are issues between the two cards. Obviously I can’t switch them, but if there is a workaround, I’d really like to hear it.

Just to be clear, the issue appears to be between the NVIDIA and the Radeon Pro 555X graphics cards. I’ll do what I can to turn them off or do other debugging.

Thanks again!

On Mac, the graphics card is controlled by Preferences-> Energy Saver. Uncheck this box:

1 Like

In my experience, macOS has been very reliable for automatically detecting which graphics an app such as SketchUp should use provided automatic switching is on (as @Barry noted), so I doubt that is the cause. Besides, @headhacker reported that SketchUp’s OpenGL preferences say it is using the Radeon graphics.

Since it was released after SketchUp 2017, it seems more likely that there is an issue with the Radeon graphics. Apple provides their own drivers for all hardware, so there is no recourse to AMD and no separate settings dialogs for Radeon on macOS. You didn’t mention which MBP version (though I could no doubt figure it out by checking the specs to see which uses that graphics).

Per @DanRathbun’s question: yes, the mac version does have the “use fast feedback” checkbox in the SketchUp OpenGL preferences.

2 Likes

It’s a MacBookPro 2019 model - 16Gb RAM. I’m not sure when they switched over to Radeon - I think it was around 2018.

I UN-checked the box and relaunched SU with the same results. The About dialog box on the Mac does show both cards as expected with this option off. I did leave it checked as @DanRathbun states, the switching appears to be working properly.

And checking or unchecking has no effect on the issue. Thanks for the suggestion.

I think it was before that. I wound up with a PC for my new notebook computer because Apple had stopped using Nvidia graphics in their MBPs.

Good to know, thanks.

This issue is not the end of the world, just annoying when the selection gets a little detailed and I really need to see what is being dragged over. Thanks all.

Some other threads FYI …

If this is happening in only SketchUp, then there’s a good chance it’s a software issue only, which may or may not be remedied. If you notice this starts happening anywhere else, there’s an incredibly high chance you have a faulty GPU card. I’ve experienced similar on-screen glitches when my video card started overheating and failing on me, and eventually it just died. Hopefully this doesn’t happen, but if you see anything, call Apple immediately.

Thanks - the laptop is < 24 hours old so I’ll watch carefully. I’ll check the temps often on the GPU as well.

1 Like

Thanks Dan - I’ll stick with Mojave until a couple of revisions are generally available.

Hmm… I probably misspoke: it looks like we have SketchUp set to always require high performance graphics, according to Activity Monitor.

You’ll also notice if you have battery life on your menu bar that clicking on it will show the apps that have this setting:
image

In the old days, we’d guess that you messed with fast feedback settings (SketchUp Preferences->OpenGL->Fast Feedback) and had disabled it, but that’s become rare in more recent releases.

1 Like

Thanks all for the quick responses. Overall, the renderings seem sharper and quicker on the AMD Radeon Pro 555x, glad I “upgraded” except for this one issue so far.

Well, can you try out the SketchUp Pro trials of 2018 and 2019 to see if they also have the same issue using the Radeon Pro ?

If so, the last resort is to report the issue to AMD graphics.

1 Like

@DanRathbun - that is a great idea - as I am considering the pro version for later this year. Be nice to know now if it shows up in the newer versions.

1 Like