Rectangle tool plays up

Hi there.

I bought a better Macbookpro that is supposed to be the best choice for interior designers students.
My last one couldn’t stand heavy 3D models.

Now working on my new Mac, here is what happens with the rectangle tool.
As soon as I move the mouse, rectangles are drawn and remained on my model.
There is nothing I can do to remove those rectangles.
Here is a picture for you to understand what the issue is.
Thanks for your help.


Looks typical of a graphics card issue. What is the graphics card in your Mac?

How far is the model from the origin?

Thanks for getting back to me.

It’s a MacBook Pro Apple M1 Pro Chip with 8‑Core CPU and 14‑Core GPU
From 2021.
Brand new.

Sketchup>Preferences>OpenGL change the state of the “Use Fast Feedback” box and restart SketchUp.

I just followed your advice.
Nothing has changed.
I still get all those rectangles …

We’re currently looking into this problem. It seems to happen on M1 Macs, if the model is demanding, if use fast feedback is turned on, and if you have the antialiasing menu set to something other than 0x.

The antialiasing setting was originally most useful when using lower resolution CRT displays, or on average resolution large screen monitors. Your MacBook Pro is 3456x2234 on a 16 inch screen. That is massively more detailed than say 40 inch HD monitor. You could set the antialiasing to 0x and not notice any jaggy lines. You would get better performance as well.

For now, while we’re fixing the underlying issue, try setting the antialiasing to 0x, or turn off use fast feedback.

It’s now working.
I don’t get those rectangles anymore.

I have been recommended to get this version of Mac to use softwares as sketchup more efficiently and faster
Other than this issue, I don’t see any difference with my last MacBook Air 2020 Quad Core Intel Iris Plus Graphic - 8 GB
It’s running even slower.

What’s your opinion about this?

Thanks a lot for your help.

One option that makes all computers look slow is Profiles. If you look at the View menu, Edge Style, and uncheck Profiles, you may be amazed how much smoother things become.

1 Like

Often understanding an appropriate workflow can increase your productivity much more than buying better hardware.


So true !

Got it.
I’m not a computer person so I get easily lost.

Thanks everyone for helping me out.

You may find that attaching one of your models could be helpful for you. People here will look through it and suggest a better workflow if it isn’t optimized.
Under 15mb can be attached directly, over that you would need to use dropbox or similar and post a link to the file.