Problem with mysterious blue square on screen

logitech
mouse
cursor
mac

#1

Hello. I have a problem. I have just plugged in a new USB mouse to resolve a ‘jumping’ about issue. This has resolved however a small blue square has appeared on the Sketchup screen a few cm away from whatever tool is selected. The square has become the ‘connecting’ point, not the tool itself. Has anyone any idea what could resolve this. I am on a MacBook Pro with OS X Yosemite 10.10.3.


#2

Perhaps this is an issue with the graphics card. You can check to see by going to the SketchUp menu (left of File) and choosing Preferences>OpenGL. Try unticking the box for Hardware Acceleration. Close Preferences. Then try again with the cursor.


#3

Thank so much for this suggestion. I just tried and it worked for the file open on the screen. I then opened another existing file and the blue square situation was back. I then created a brand new file and it was still the same. The separation with blue square. Another issue is for some reason the line thickness on the drawings has become varied and jagged/fuzzy. Any help very much appreciated.


#4

Those behaviors are indicative of OpenGL issues with your graphics card. You might also try turning off Fast Feedback in the OpenGL settings and see if that helps.

I’m not sure if there’s anyway to update the driver for the graphics card but it would be worth looking into.


#5

Fast feedback is greyed out. This is a very new Macbook Pro. I wonder how this happened. I don’t know anything about Graphics Cards, or how you update them. Thanks for your advice so far, I must continue to try and resolve this.


#6

Generally, if there are updates, they are shipped with the OS.

Your profile indicates you are using OSX 10.9.5. with Intel Iris Pro graphics card. Is this still the case? Did you update the OS version or are we talking about a different MacBook Pro?


#7

I am in fact working in Sketchup on a different MacBook Pro, OSX Yosemite 10.10.3 with Iris Intel 1536 MB.


#8

Updating Yosemite to 10.10.5 will update the drivers if needed…

john


#9

Hello John. I just checked my upgrades. I could also update to OS X El Capitan 10.11.1. Or maybe this is not good idea and Yosemite 10.10.5 is a better option?


#10

Yosemite update will be quite fast and you can see if the problem is solved before the move to El Capitan…

I keep putting it off myself until the next SU version arrives…

john


#11

I am downloading now and will see if that works. I just tried Sketchup on my other MacBook Pro, same files downloaded from Warehouse, same just-purchased mouse and it worked fine. No mysterious blue square pretending it is the end of the pencil tool or tape measure (for example). So for sure the problem is within this Macbook Pro. I will see what happens …


#12

What year is your MBP? There was a recall for certain models having issues with the graphics system:

https://www.apple.com/support/macbookpro-videoissues/

Your symptoms sound different, but if the OS update doesn’t fix them and yours is one of the affected models it would be worth checking.


#13

Thanks for this. In fact it’s quite new, purchased a few months ago. I am working on the system update. I couldn’t update to Yosemite 10.10.5 so am now downloading OS X Yosemite 10.10.5 Combo Update. If that doesn’t work it will have to be El Capitan …


#14

I am now in OS X 10.10.5. Sadly the small mysterious blue square, that thinks it’s the end of the pencil and is drawing lines parallel to pencil movement, is still there. One has no control of a drawing.

I know I can restore order to Sketchup which was working so well on this new and barely used MBP. I wonder if it’s the new Logitech m90 USB mouse, although that works fine on my other MacBook Pro. The problem started when it was first attached this morning in an attempt to solve the ‘jumping’ about with former mouse.


#15

Yeah, I’m gonna go with graphics card and/or drivers for it.


#16

@Rick… it’s a mac…

@helen, did you instal Logitech drivers?

they are not normally needed, and can cause more issues than they solve…

did you adjust any Mouse Preferences in System Pref’s ?

john


#17

I didn’t install any Logitech drivers. Didn’t adjust any Mouse Preferences … should I have done this?


#18

I have a Mac and a Logitech mouse and I can say that the difference between using the stock driver vs Logitech drivers is night and day. Logitech puts a lot of features in their drivers, too. Well worth installing.

http://support.logitech.com/en_us/category/mice-and-pointers


#19

The easiest way to nail this down might be to borrow a different mouse (not the same model Logitech in case it is indeed a driver issue) and see whether the problem persists or goes away. If it goes away, your simplest fix is to buy another mouse!


#20

Thanks for coming back. I agree, I will try a different mouse first thing tomorrow. If the mysterious blue square disappears I will be overjoyed. The strange thing is when I plug the Logitech into my other MBP it works fine however there is this ghastly sinking feeling that any minute the blue square situation might occur. Grateful to everyone for thinking about this and helping. Thank you so far …