Jagged lines and selection box issue SU 2015


#1

Hi everyone,

Been using Sketchup for a number of years now on a Windows laptop, no real issues just a bit small and slow.
I’ve recently upgraded to SU 2015 and purchased a new iMac to hopefully improve speed, quality etc… So far pretty good however, edges on my designs seem to appear jagged whereas on the previous version on the laptop, edges seemed a lot smoother! not too sure if I just have to put up with this or I can maybe change a setting to improve things? any help would be much appreciated.
Also, one small issue with the selection box using the pointer. When I hold down the left mouse button and drag to select a number of items the selection box lines appear to smudge or smear almost creating a 3d effect! seems very odd and not sure how to rectify this either, although it still selects the chosen items ok.

Many thanks.


#2

Sounds like a graphic card issue, you should change the opengl settings in the preferences and see if this helps. Make sure you have the latest driver for your graphic card installed too.


#3

Hi Cotty,

Thank you. This is going to sound stupid but is it possible to upgrade the graphics card driver in an iMac?


#4

Apple updates all drivers automatically with system installs. Provided your OS is up to date, there are no available driver updates. What screen resolution mode do you have set? If it is not one of the “native” ones for your display, it is interpolated by the hardware and that can cause a bit of fuzziness.


#5

I’ve recently downloaded Yosemite, this morning in fact, which means the drivers should be bang up to date! Is there anything else I can try?


#6

We crossed while I was editing. See previous post.


#7

Sorry about that. The current setting is 2560 x 1440.


#8

You have tried this and it doesn’t change the behaviour?


#9

Yep. Tried this with no change, just poor resolution. I’m surprised that an iMac which is primarily used for designing etc… is having this much trouble with SU. I was under the impression that there would be no problems and this should be plain sailing.


#10

That’s native for a 27" iMac. There are some issues in SketchUp with very high dpi displays, but what you describe doesn’t sound like what I have seen. Open Finder, navigate to Applications/SketchUp 2015, right-click SketchUp, choose Get Info, and see whether the “Open in Low Resolution” box is checked.


#11

There doesn’t seem to be an “open in low resolution” box under the “get info” window.


#12

That’s odd. There should be…


#13

Thats very odd! Now I’m really confused (I know it doesn’t take much). Everything else seems identical between the two windows. What next?


#14

I guess we wait and hope for someone with an iMac 27 to chime in…I’m on a MBP retina, which also has high-dpi issues but not what you are describing. I’m out of ideas…sorry!


#15

No probs. Thank you very much for your help and time.


#16

If you open the Ruby Console and type

Sketchup.active_model.active_view.vpheight

in the input region at the bottom, what does it say?

One additional silly sort of thought: what style does your model have set?


#17

It says exactly what you typed but with the number 1238 at the end. Also the style I’m currently using is Architectural.


#18

Hi
If anyone still has this problem, I solved it using the same Ruby hack I used for v.8, posted by John Bacus here in 2010. I can’t find the thread anymore, so I hope John won’t mind if I paste it in:

"Hi eternalevents,

CAUTION: This is an undocumented hack that isn’t habitually tested by our QA team– though it may give you the ‘look’ you’re after, it may cause unexpected issues elsewhere in the application.

  1. Choose “Window > Ruby Console” to open the Ruby Console
  2. type the following into the console:
    Test.set_AA_method(4)
    …and hit Return.
  3. The console should echo back to you something like:
    0
    …indicating the previous anti-aliasing setting was “0x”
  4. Quit SketchUp and restart. All SketchUp windows will now have 4x anti-aliasing enabled.
    Hope this helps- and remember: this isn’t guaranteed to work on all Macintosh models.
    john"

    “To set SketchUp back to “no anti-aliasing”, you would type the following into the Ruby console:
    Test.set_AA_method(0)
    …and hit Return. As before, you’ll have to restart SketchUp to see the effect.
    john”

R