Selection Tool leaving a "trail" since Mac OSX 10.13.4

mac

#1

Hi, Have been using SU for years and recently downloaded a trial version of LightUp and the new Mac OSX 10.13.4 update.
The selection tool now leaves a trail of dotted squares across the screen.
The guides also move when drawing - like a stream of dots marching along the lines. It’s very disconcerting and distracting and starts to make the eyes go a bit funny after a while.
I’ve been in touch with LightUp and they say that SketchUp is unaffected by their software (however I had an extraordinary amount of crashes while trying to get it to work).
I have now uninstalled LU but the dot problem is still there - any ideas please?


#2

If the trail is only on the 3D viewport, it is a graphics driver issue. With new OS versions come also new drivers that might introduce issues that haven’t been there before.

Check in SketchUp > Preferences > OpenGL whether you can turn off “fast feedback” as a workaround.


#3

Thanks for the feedback. I turned off fast feedback as you suggested but it has made no difference…


#4

A bit of an update - I just reloaded SU 2016 and it works fine. Trouble is I can’t open my newer files😬


#5

In Preferences>OpenGL for SU2016, do you have Hardware Acceleration disabled?

It’s unfortunate but clearly the graphics drivers that Apple supplied for your computer’s GPU with the current version of the OS is not up to handling OpenGL correctly. We see this from time to time. With Mac you usually have to wait and hope that they have another update for the GPU drivers soon.

You can upload those files to the 3D Warehouse through your browser and then download the 2016 version.


#6

Thanks Dave R - hardware acceleration is “on”. I take it that’s the correct setting?

Thanks for the upload/download tip.


#7

There isn’t one correct setting. It depends upon the graphics card/drivers. If you don’t see graphics issues with it on, you can leave it. With SU2016 and earlier, the option to turn off Hardware Acceleration was available. This dumped rendering duties back to the CPU. With SU2017 that option was removed. The GPU normally does a better job of rendering for display since that’s its raison d’être.


#8

Thank you for the info Dave :grinning:


#9

Good luck. FWIW, next week you might get another update from Apple that includes a fix. Or you might not. Still it wouldn’t hurt to check periodically to see if the problem resolves.

Long shot: Have you tried quitting SketchUp and shutting the computer down entirely before rebooting?


#10

Yes - I did a full shut down earlier on. Have just been messing around with SU 2016 and LightUp with no problems. Couldn’t get LightUp working without crashing on SU2017…here’s hoping Apple fix it!
Thanks again.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.