Seeing lines as I draw across a face


#1

Hi Guys - I have been using sketchup for the past 8 years but took a hiatus for a year and just downloaded the new version. I feel like this is a stupid question but was hoping for some help.

I am working on floor plans and field layouts and when I connect a plane to create a surface, I can no longer visually see lines as I am drawing on top of the plane. For instance, I am working on a floor plan right now and I drew the outside rectangle of the room. The plane was created, however now when I go to draw interior walls, i can see my mouse and the cursor, but can not see the line as I am drawing it, making it very difficult to know where I am drawing in the floor plan.

Hopefully this makes sense and thanks for the help!

Jim.


#2

A screen shot or something would be useful.

What version of SketchUp are you using?

One guess, though. Try turning off Use Hardware Acceleration under Preferences>OpenGL and see if you get a different result.


#3

Thanks for the quick reply Dave. I am on a Mac using version 15.3.329

Attached screenshot shows two dots, my pencil line tool is actually on the right blue dot but doesn’t show because I was taking the screenshot. I can see where my line starts (dot) and ends (dot) but the line doesn’t show up. I can typically get the line to show up when i scroll zoom in our out with my mouse but this isn’t a very good solution if i have to zoom in or out every time I draw a line.

I tried Hardware Acceleration but it didn’t help with the problem - good suggestion though!


#4

Also, I have noticed, it typically only happens as I am using the straight overhead view. If I slightly angle the view, it isn’t an issue. Again, drawing floor plans and field diagrams, its always a bit easier on the eyes to be looking straight overhead vs. at an angle.


#5

Interesting. What happens if you delete the face? Can you then see the line being drawn?


#6

Sounds like your face may be slightly above the axis and your pencil is drawing on axis. Therefore underneath the face.


#7

Yes - if I delete the face or hide the face I can see the line being drawn. It appears to only be an issue when the face is unhidden with a direct overhead view. I have two macs and I am having the same issue on both - only had this issue since downloading the Sketchup 8 or newer.


#8

I just checked to make sure and started my face at the actual axis point and still having the same issue


#9

It looks like the line version of surfaces “Z-fighting”. I see that some times on my mac. Once I click the second point, the line shows up.


#10

Have you been able to figure out any fixes to where you can see the line while you are drawing it? When I finish the line it shows up, but once I am getting into high level of detail on some of the plans, it becomes very difficult if I can’t see the line while drawing it

Thanks!


#11

Out of curiosity, what happens if you reverse the blue face so the front face is up?


#12

I think that scale plays a factor here, too. What is the size of the rectangle in the image you posted?


#13

same issue when reversing faces


#14

the rectangle in the posting is only 19’ x 19’


#15

Check your OpenGL settings in Preferences. Is “Use Hardware Acceleration” turned on?


#16

I can replicate your issue by moving a face .1 mm up then drawing from above.
It is intermittent and I believe it’s related to opengl and small dimensions.
What sizes are you working in? Are you pushing limits?

Edit. Slow phone posting.


#17

Hmm…I can’t reproduce this on my MacBook Pro Retina, even trying what Box suggested. So, a bunch of questions:
-What version of SketchUp are you using (your profile just says “Pro”)? In your posts you only mention “SketchUp 8 or newer”. Edit: oops! I see you did say 15.3.329.
-What version of Mac OS are you using (your profile just says “MAC”)?
-What model(s) of Mac are you using?
-Can you look at the Apple menu->About this Mac and see what graphics you have? Note: have SketchUp running while you look, so that if you have an enhanced graphics adapter it will be shown.
-What are your units settings?
-What Camera projection?
-Do you see the “On Face” tooltip before you click the start point and at the end point if you hover the cursor for a moment?


#18

I turned it off but didn’t seem to make a difference


#19

Sketchup Version 15.3.329
Mac OS X Yosemite Pro-Reina early 2015
2.7 GHz Intel Core 5
Graphics: Intel Iris Graphics 6100 1536 MB
Units settings: Simple Template Feet and Inches
Camera Projection: I see the options but not sure how to tell which one I am currently using

On Face: I see the on-face prompt before I start the line, however once I click and start drawing all i see is the start blue dot and the end blue dot as I am drawing. Once I click to finish the line, the line appears. I am also on the face, as I can draw a box and it will create a closed box on the face - I just can’t see the lines as I am drawing them.


#20

I’m stumped. The only idea I can think of is to try resetting the PRAM (there are some reports of display issues with the 2015 13" rMBP that this action fixes, but they didn’t involve SketchUp).

here are instructions on how to reset PRAM