My tape tool is hidden under model

Hi, Sometimes when I use the tape measure and line tool it is hidden under the model or it is not visible when being drawn. It happens in parallel projection and perspective. I’ve been using Sketch-Up for a while but this only started happening recently. Sometimes the tape tool and line tool doesn’t snap to a line as well. Any help!?

It would help us help you if you could share a model in which you are seeing this.

Hi, let me know if you can see the video! Thanks

could it be related to this ?

in this thread, it appears that from time to time, both guidelines and crosshairs will appear behind faces instead of in front.

edit : from your video, I’m tempted to say it’s the same bug.

1 Like

Ok, I am taking a look at the other feed now. Is there any way to fix it?

Are you using the new graphics engine or the old OpenGL engine ?

How can I see that :sweat_smile:
This is exactly the same problem as mine!
I’m on 2024 on Mac Studio M1 max.

1 Like

How do I check this? I’m not sure


SketchUp > Preferences > Graphics > Graphics Engine

MS Windows

Window > Preferences > Graphics > Graphics Engine

… choose. The choice is new or “classic” (ie, the old OpenGL engine.)

Thanks, could one version be causing the issue?

This is why the question was asked.

So, if you can tell us which graphics engine it occurs using, and then try it on the other, we may know the answer.

It says new graphic engine
Thanks so much for the help

Okay, … now can you try to reproduce the issue using the “classic” graphics engine?

I tried it and the issue seems to have not persisted. But can you tell me why this might help or what changing the engine does and how it will effect the drawings?

Apparently, the bug is only with the new graphics engine (which uses Metal on MacOS.)
So, it allows you to use the Tape Measure tool without the bug.

I do not know as I do not have a Mac.

What MacOS edition and version are you running ?

Is your Mac an Apple silicon or Intel CPU ?

I have this same problem, but saving the file always fixes it. I’ve come to appreciate the problem because it reminds me to save.

I always had a habit of pressing Command S to save every few minutes and it still was an issue :frowning:

Great to know thanks

Hi I was working again and the issue is still happening even with the graphic change