Lines from behind showing after zooming out

Hello Sketchup users, I have a problem in my drawing. When i zoom out, the lines from hide objects are showing but after zooming in all lines are gone. I want to remove that lines because i’m trying to print screen on my drawing and make a jpg file of it. I don’t use export as jpg cause the line are very thin when exported.TIA

See attached image below.

Use the Eraser + Ctrl to hide the offending edges.


Sir @Geo its not a offending lines, they are lines from the objects below the Steel sheet cover.

See attached image below.

Also see this attached .gif if you can’t understand.

Make the steel sheet cover have some thickness (You can exaggerate the 1.2 mm thickness currently indicated - give it a discernible top edge and a bottom edge). It does not need to be very thick. This should effectively conceal the hidden lines that appear below it when you zoom out.

1 Like

@jvleearchitects so i will mislead the original size of my steel sheet to remove it?

Yes, I’m quite aware of that.
The “Support Angle Bars” have edges (lines)
Use Eraser + Shift to hide the topmost edges of the Support Angle Bars.

@SketchupKage01 For your interest:

Are lines showing through faces from a distance? — SketchUp Sage > Problems > Other Annoyances

Ahh ok sir, i get it now. Just a little misunderstanding here hehe. By the way thanks for you help Sir @Geo and Sir @jvleearchitects. Godbless.

1 Like

Page not found Sir.

Well, it’s up to you, of course. You as the designer are entitled to take a degree of liberty with the level of graphic precision in your delineated documents, especially if your exaggeration better conveys your design intent. The perceived difference in thickness from 1.2 mm to even 2x that thickness is negligible when viewed on paper or on screen. Furthermore the accepted universal convention suggests that the written dimension supersedes graphic or scaled dimensions on drawings. Many (if not most) licensed professionals will typically include a general note similar to the following on permit drawings: “Drawings shall not be scaled. Written dimensions shall govern in all cases where indicated within these documents;”

Oops … I clipped off a couple of characters copying the URL
Fixed.

Just to illustrate Geo’s advice, as it’s an oft asked question.
Here are two sets of rafters under a roof, the only difference is the top edges of the left set of rafters have been Hit with Shift Eraser to hide them.

3 Likes

Some more infos about this from Gaieus:
http://sketchucation.com/resources/tutorials/beginner/315-edges-bleeding-through-geometry

2 Likes

Perhaps Thom Thom’s SuperGlue extension might help in this case? You would make those lines/bars a component and then “SuperGlue” it to your face.

Thanks,
AlexB

Edges bleeding through faces when viewed from afar is an unfortunate facet of OpenGL rendering.
The issue has nothing to do with Component Glue To properties.
SuperGlue won’t help, nor will duct tape.

1 Like

White out might be worth a try.

Shep

1 Like

@SketchupKage01

Gaieus’ article supports my suggestion to give the steel sheet a bit more thickness (arbitrarily). It seems to be a very easy way to address lines bleeding thru from below. Obviously the process of hiding the offending lines or placing them on a layer that is turned off works equally well, but it’s just a tad more convoluted as a workaround IMHO.

More convoluted perhaps,but your model remains accurate. In my example above, as the “rafters” are components, it was barely two clicks to hide the edges for all of them. And the roofing material thickness need not change.

2 Likes

No matter how much thickness you give it, this will still happen if you zoom out sufficiently far. It has to do with the ratio of the amount the line is hidden to the apparent distance from the object. If you double your top to 2.4mm, you will be able to zoom out about twice as far before the lines show up.

It seems the best suggestion for a workaround is to thicken the top, and rather than make a general announcement that the drawing is not to scale, note that this particular dimension is NTS for clarity. Otherwise, you have people searching all over for misleading areas of the render when it’s very local. They might even miss it.

Hence hiding the edges is far more appropriate.

1 Like