Seeing Edges Through a Face

Continuing the discussion from Welcome to the SketchUp Community!:

Use the Eraser Tool + Shift to hide the offending edges.


There are additional infos about this topic here:

Hello Cotty, I’m a recent add to this forum but a long-time Sketchup user. I specifically joined the forum looking for an answer to this very issue - lines bleeding through when zooming out. I read through the link you provided. Given this topic is 7 years old, do you know if there have been any fixes or methods to address this? I’m on Pro 2022 if that’s of any use.

AFIK this is a function of the graphic implementation used. This hasn’t changed. Usually when objects have proper realistic thickness, edges of objects beyond will bleed through less. Also you may find that output, print or otherwise will have better results than on screen.

If you must get a certain view and zoom, such as a roof top view from SketchUp or LayOut and the roof sheathing is not hiding the rafter edges (for example) below.

  1. You can hide the rafters tag for that scene, since you don’t want to see them anyway.
  2. You can hide the top edges of the rafters permanently, as this won’t affect most views.

(this is just an example)

Thanks, pbacot. I think workaround #1 in your reply will be easiest in my situation which is as you described - rafters bleeding through the roof sheathing. Do you know if I were to group the sheathing with the rafters if that would eliminate the bleeding or does the bleed-through happen regardless? (I’m not at the specific computer with that file so I can’t try this at the moment). Thanks.

Grouping like that won’t change this issue. As long as the rafter edges are visible and the sheathing is of normal thickness, those edges will bleed through due to the way OpenGL works.

I would tag the rafters separately from the sheathing and then, if needed, turn off the tag visibility for the rafter components leaving the sheathing in place.