Joints (edges) visible through thin materials - How to hide?


#1

Noobie here!

I’m trying to learn and I am therefore creating simple sketches so far.

I have created two boards that are at right angles to each other. Each board is 4’X8’ and 2" thick. Therefore when viewing from the front, the face of one board is visible while the 2" edge of the second is visible.

Now I have created a very thin “tape” that will be applied over the corner. The tape is thin, 0.04" thick. The tape was made by drawing two lines perpendicular to each other, offsetting, connecting. A material was applied to the 2D area then pulled to length. The tape was then moved into position on top of the corner.

I have created a group of the two boards. The tape is also its own group.

In real life the edges of the boards would not be visible but they are visible in the model.

How do I turn off edges that shouldn’t be visible?

I have tried the keyboard k shortcut and that didn’t do what I needed. It turned on more hidden lines that were correctly hidden in the first place.


#2

You can edit the groups and hide the edges:

Eneroth 3 has an extension:


#3

Thanks Mike for the option. I have now learned something. This does make the like go away completely for the entire joint. However, it just needs to be hidden behind the tape. Above the tape the joint is still visible as well as the edge of the board.

As the graphic is changed, the height (length) of tape may change. I could hide the entire edge then just draw in the line above it and below it but that is problematic.

Why doesn’t the thin tape hide the edge in the first place? The tape has a material assigned that is opaque and thickness so therefore, there are two faces of materials that the edge is “Bleeding” through. What am I doing wrong?


#4

This is due to how your graphics card handles WebGL and decides what edges should be shown and which ones should not. If you zoom in very close you’ll see the thin tape does hide the edges underneath. As you zoom out, the difference in distance to the camera between the surface of the tape and the edges behind gets closer to zero and due to tolerances in the graphics display, at some point the card decides they are the same distance.


#5

Also make sure that the material for the tape is not set to be transparent. (Ie, it should be fully opaque.)

To test, write out an PNG image and see if the hidden edges still “bleed” through.


#6

Only solution I know of would be to make the tape somewhat thicker. Yes this is a quirk that is rather ubiquitous in Sketchup.


#7

Dave, You’re spot on. Zoom in and it goes away and zoom out, poof there they are. Ugh. This is quiet unfortunate.
Are there are tricks that you know of to help this?
Michael


#8

#9

The only solution I know is to hide the edges you don’t want to see.

As @MikeWayzovski, mentions, there are extensions that can help IF you are using a desktop client version of SketchUp. It’s not at all difficult to hide the edges with native tools, though.

Here’s a quick example. On the left is similar to what you have. On the right, I’ve hidden the edges on the “boards” behind the tape. Notice that even though that one is farther from the camera than the one on the left, there’s no edges showing through the tape.


#10


I selected the tape group, edited it, selected all within the group and changed the material to some landscaping rock, exported as a png file. The line is still there unfortunately.
Based on the other answers, it doesn’t sound like this is a “fixable” problem. I either make the material thicker, move it further way from the object below, or just don’t zoom out.
Frustrating.
Thank you for the tip though. I am learning each time everyone in this forum posts!
Thanks to everyone for replying.


#11

See my edit, above.

Understood. It’s a limitation of OpenGL and WebGL.

This sort of thing is common in models of roofs where the trusses show through the sheathing when looking at the whole structure. In a situation like that, the fix is to use layers and control the visibility. Put the trusses on a layer that can be turned off when you’re looking at the sheathed roof. No point in having the trusses there if you can’t see them anyway.

How will you be using your model once you have it completed?


#12

Thank you Dave.
I’m using the web based version. All of that is possible but a bit cumbersome. If something changes or the tape moves, all of those elements would need to be updated.
Based on the above comments, I may ending up using your technique to “fix” the finalized version.
Thanks again! I really appreciate your help.


#13

What will you be doing with the finalized version?


#14

There are multiple uses for the final version. The attempt is to create a useful model that can be used differently depending on the request of the multiple groups. So unfortunately, the final use of the model is still fuzzy.


#15

I saw an older thread where y’all show the object needs to be at least 1 inch thick.

Has this issue (bleed through) improved any with OpenGL 3 (SU2017+) ?

I’ve noticed that all 2D image export direct from SketchUp shows the bleed through, except PDF export. (But strangely from SU2016 the PDFs have no textures.)


#16

I have no real knowledge of how it works, but my impression from observation is there is some percentage of the distance from camera that comes into play. From a distance, framing bleeds through plywood sheathing, but as you zoom in closer, the bleeding stops happening.


#17

Yes, Robert I have the same ideas, but I was wondering you (or anyone) has seen any decrease in this bleed through in the last 2 versions of SketchUp which tout that they are using OpenGL 3 (instead of the previous versions using OpenGL 2.)

Also wondering why the PDF export is so drastically different than the image exports that use the FreeImage library. I notice a huge difference if the view is used as a viewport for LayOut and the PDF export is done from LayOut instead of directly from SketchUp. (FYI, SketchUp’s PDF exports use a german PDF library.)


#18

Dan and RTC,
I am using the online web version of the tool and therefore, I am assuming they are using the most recent software on their side. On my side, I have updated all of my device drivers from operating system, graphic cards, and monitor drivers. Hopefully, if an update was available, I have it installed.
As for the material. The boards are typically one-inch thick but the tape is the thickness of very thick tape, about 0.04 inch.
It clearly is an issue with the distance of the camera in relation to the thickness of the second layer. When I zoom in for a detail image, the line goes away. When I zoom out, the line appears.
As for the difference between the paid version and the web version remains to be seen. At this point, I think it is what it is going to be. I either have to make the tape much thicker and not show details that would reveal the overly thick tape, make multiple models, or wait until the final edition and delete out lines where needed.
Thanks for everyone’s help and input. This was a great learning experience.


#19

In the case of the browser-based editions, it matters more about your side since it is running in your client-side browser application. There is a switch that allows older machines to run the SUfW editions in an older WebGL mode.

Anyway, I am kinda more concerned with presentation, ie what exported images of the view will look like, or what the internal view looks like during a Zoom desktop share situation.


#20

I don’t think it is a question of OpenGL version per-se, but rather of the z-buffer depth chosen by the software. The shallower the z-buffer, e.g. 16-bit, the larger the separation must be to avoid bleed-through or z-fighting. But even with a deeper z-buffer, the problems will occur if the camera is far enough or the model is large enough.

I have always suspected that the SketchUp developers make conservative choices on such issues to avoid a flood of complaints from people whose hardware or its drivers can’t handle higher settings.


Lines show through surfaces