Textures transparency


#1

I cant figure out why this is happening


#2

Looks to me as if the planking has no thickness or very little and your graphics card is showing the joists through it. This isn’t unusual. The way to handle it is to put the joists on a layer of their own and turn off that layer’s visibility when the joists aren’t needed in the scene.

Did you draw the planks as separate components or are you using a large face with the material painted on it in lieu of planks?


#3

Thanks for the reply DaveR,
This was a file sent to me by a customer (I am a lumber estimator) and since I’m teaching myself Sketchup
I thought I would create the appropriate framing behind the material painted thin face provided by the customer.
I even held the framing away from the material painted face by 1/8" and it still shows through.
I have already done what you suggested and put my framing on another group AND another layer. I was just trying to use it as a learning experience in textures and materials. How to not see something like this is the future it I were to create framing geometry with a material painted face.


#4

This is something I wish SU would fix, it annoys me to no end.


#5

Due to the way OpenGL works, the distance between the top face surface and the geometry behind it as a proportion of the distance from model to camera affects the display. The 1/8 in. gap is large enough that the nearest end of the joists doesn’t show through the deck face but as you move back in the model, the 1/8 in. isn’t enough.

That’s a good thing to learn to manage. We often see this crop up in models of houses where the trusses show through the roof when looking at the entire house from a distance. In this case, putting the trusses on a layer separate from the roof make it possible to skirt this display thing.

If I were drawing that deck, I would draw the planking at its actual dimensions using components for each plank. If each piece of wood is made as a component (and identical ones copies of a single component) it is the work of a couple of seconds to generate an accurate materials list. Drawing the planks at their correct thickness would also result in the joists being properly located and for no bigger than this deck is, the joists most likely wouldn’t bleed through.

FWIW, if you are going to be using SketchUp for work with your customers, you’ll need to use SketchUp Pro instead of Make. That’ll give you access to LayOut which will be useful for creating condocs and other documentation you’ll need.

It’s caused by the way OpenGL determines what is in front of what to create the 3D display. Perhaps there’s some replacement for OpenGL that would handle it better?


#6

Sorry to focus on a slight tangent of this thread, but in general how would you create a materials list, given a model that has components for each individual piece-part of a construction? I will soon be drawing up the final model for an entryway bench and shelves that I’ll be building. I assumed that I would need to more-or-less manually add up the linear feet of this, of that, etc. I have SketchUp Pro 2016, 17, and 18. I’ve never used Layout other than 30 minutes of experimenting a couple of years ago, for what that’s worth. I’ve used the SketchUp report generator a tiny bit.


#7

I use an extension called CutList by Steve Racz which is available from the Extension Warehouse. There are other options as well but I find Steve’s to be the easiest and fastest to use. See this link for more on that.

As for LayOut, it’s a great tool for creating the plan document you’ll take to the shop after you’ve got your model made and the various scenes created in SU. I do all the dimensioning and notes in LO instead of in SketchUp.


#8

I’m going out on a limb here since I’m no developer and don’t know the ins & outs of OpenGL or how SU (or other softwares) leverages it or displays things.

But this problem has been around for a long time. Before OpenGL hardware acceleration was a requirement, you could switch off OpenGL hardware acceleration and the problem was still there.

Granted, I have not worked on many different CAD / modeling softwares, many (if not all) of which also leverage OpenGL technology, however I do not recall seeing this problem in any of those. I would expect to see something of this nature when you have a plain 2D plane with other elements touching said plane (in effect like Z-fighting), but not when you’ve modeled thickness to something and you still get geometry showing through that should have been culled from view.

Needless to say I was sad to see this problem persist after the upgrade to the SU graphics engine was done.


#9

here is what the helpcentre says:

https://help.sketchup.com/en/article/3000086


#10

learn to use scenes and layers and the problem goes away


#11

yes, but it shouldn’t be that way, no?


#12

Perhaps but it isn’t the only reason you need to learn how to use scenes and layers.


#13

So I’m not the only one who’s OCD facial tick goes off when i see stuff like this?


#14

No but you should be aware that facial tics become permanent after two versions… and causing a scene isn’t the same thing as creating one:)


#15

Are all the vertices on the same plane? Also, a way to prevent transparency is to give the deck it’s actual thickness and make it into a group. Maybe 1.5" thick?


#16

Thickness won’t fix it, as you zoom out it will still bleed through.
Here is an example I did a couple of years ago. Hiding the edges stops the bleed, but it’s not always a better option than using a hidden layer.


#17

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.