Section tags in Layout

Heyo: i had my sketchup scenes set to show section planes in elevation and inserted the scene into layout. I adjusted the style to keep the section planes visible in the scene but the section cut is turned off so my section tags from SketchUp were visible in layout. Setting the viewport to “hybrid” in layout allowed me to view the section tags. Today when I reopened the layout file the section tags disappeared though they are still visible in Sketchup. Nothing changed in the viewport settings and I relinked the models/files, etc. The section tags will not reappear in the layout viewports though they are clearly visible in sketchup within their scenes. Any advice?

I don’t recall them being visible in other styles than raster, might be that it wasn’t fully updated when switching the first time.

In the SketchUp tray in Layout when you select the viewport does it say “modified”?

Thanks for the follow up ya’ll.

Mike: I currently have viewports set to “hybrid” which do indeed show the section tags so I don’t see that as the issue.

Nick: I don’t see the “modified” field in the Sketchup tray in layout. Could you send me a screenshot of where it is in your version? I am in the most recent version of Layout but (I should’ve have mentioned) on a Mac.

It’s possible the issue originates within SketchUp. I have found sometimes when I reopen a model the section tags are not visible from the view in the offending scene. If you rotate just a little bit they reappear. Annoyingly that means I have to cut and paste the back in place in each scene, assign the active cut, and hide the outline of the active cut, update the scene, save, update in layout, etc.

In LO2021/2022 it won’t say “Modified”. Instead there would be a Reset button displayed.

Can you share your LO file so we can see what you have set up?

FWIW, I just did this from a file I happened to have open. As you can see, the section plane is displayed with Hybrid rendering.
Screenshot - 9_17_2022 , 11_13_25 AM

1 Like

no reset button visible; i thought it used to be next to the lock icon?

trying to upload the file but the uploader in the reply tab says the copy of the file I saved has zero bytes. And yet it is 2.7MB file :person_shrugging: :person_shrugging:


Try uploading it to DropBox or WeTransfer and share the link.

I’m getting old!…you’d think that would have set in over 12 months, considering I use this feature often. Better get it together in the next week, LOL! Listen to Dave, not me!

1 Like

thanks again for looking at this

here’s the WeTransfer link

I’m seeing your section planes in all of the viewports in your LO doc. Example below.

Are you not seeing them now?

Thanks Dave! yes i’m seeing them now as well…I guess I’m wondering why they disappeared within the SketchUp Scenes when nothing in the view properties had changed. As I mentioned slightly rotating the model made them reappear but they disappeared from orthogonal views until I cut and re-pasted them in…maybe it’s one off behavior I dunno.

on a somewhat related question: do you know if there’s a way to edit placement of the arrow and tag of section planes within SketchUp so one case get them fitted better within viewport. I know one can place these within Layout but I like the idea of not manually locating them.

Thanks again for all the help

I wonder if it was a temporary graphics card thing. No idea. Problems that resolve themselves with no clear reason why have always bugged me. It was especially annoying when I worked on anesthesia and other critical life support equipment.

There isn’t a way to adjust their positions. The size is set based on the size of the part of the model that is being cut. It might work in some cases to create a group/component of a smaller collection of elements and put the section cut inside.

Example. the largest section plane is in the model context, the long skinny one is inside the selected nested component, and the small one is inside the small sprocket component. Maybe you can leverage that somehow in your models.

hmm ok i’ll play around with the nesting options.
Hopefully the problem of disappearing section planes within sections does not recur!

oh man, it’s doing it again.

Share the LO file so we can see what you’re working with.

it appears to be an issue with the Sketchup file and section planes disappearing in orthogonal views (again they reappear if I rotate the model ever so slightly). Should I share the offending .skp file?

Either one. If you share the LayOut file the SketchUp file will come along with it.

thank you so much dave here’s the link
take a look at the last page in layout “master closet” the section tags are visible in sketch up but do not appear in layout. I tried resetting the styles to no avail.