Section Planes Disappear in Parallel Projection view

I created this small test file for applying section planes and cuts using a single style. When I use a standard camera front view in parallel projection (Scene 9) and toggle the section planes On, they are not visible. Orbiting or going into perspective camera view shows they there. Can anyone please view the file and provide suggestions.

section cuts test.skp (304.0 KB)

That is something we know about, and have fixed for the next update (can’t say when that will be available).

Can you try this file, and see if things seem ok?

section cuts test.skp (435.8 KB)

When I open your file (last saved as a SU2020 file) in SU2022 I see no difference, the section planes do not appear when toggled On.
If however, I open either your file or mine in SU2021 then I can see the section planes appear once toggle On.

I see that difference. I will log a new bug report about that.

Thanks Colin. Not sure what happened with this file that caused this to occur. I know in other files the section planes appear normally in Parallel Projection. Will look for a fix in the next release.

I think it’s a side effect of a fix to another issue. Nothing that you did in your model.

For colleagues dropping by, I logged this as bug SU-51490.

do we know when this will be sorted?

Help! I have just encountered this bug on a very important file I have been working on for months - I have to submit to a client and can’t get the section planes to show in parallel projection view (and in Layout) - can you let me know when this bug fix will be released?

What rendering mode are you using?

I’m not sure if this is a Mac-specific bug but I don’t have any problem on my PC showing section planes in a Parallel Project view in LO. I used Hybrid render since the section planes are a raster image and won’t show with Vector rendering. Below on the left is my single viewport. On the right I have stacked a couple of viewports. The bottom one shows the model rendered in Vector and the top viewport with only the section planes rendered in Raster. The section planes are tagged so their visibility can be controlled independently from the rest of the model.


Perhaps, at least until the bug is sorted, you could use this method to get your work out the door. As for when the bug will be fixed, the SketchUp and LayOut folks don’t share that kind of information until it is fixed and the update is released.

I just tried another test using the test file from my original post above. After toggling Section Plane visiblity to ON in scene 9, which is Parallel Projection Front view, as before, the section planes are not visible.
However, when I go into the outliner and shut off section plane 1 visibility setting then enable it again, all the section planes are now visible in the Parallel Projection view. Unfortunately, after saving the changes in SketchUp, and then bringing the file into Layout I am still not able to see the section planes visible for that scene in the Layout Viewport. Wish I had better news.

@DaveR , I am using a Mac so perhaps it is another Mac specific bug.

Thanks for the suggestion

Same here, toggling visibility in Outliner brings then back, but they don’t persist between reopening the file and between Sketchup and Layout.

Here’s a video link showing a screen recording. Switching between parallel and perspective, toggling Outliner visibility. Screen Recording 2022-10-03 at 10.42.05.mov

Since the outliner toggling doesnt get saved, its just an interesting part of this bug but not a true workaround.
As I noted in an earlier post, SU 21.0.392 does not have this issue. I was able to open, save and send to Layout (same 21.0.392 version) with all section planes visible in Parallel Projection view. Perhaps that can be used as a workaround. Another possiblity, draw the section planes manually in Layout. I keep some section plane symbols in my Layout scrapbook and place them manually since many times the SU section plane symbol text is unreadable. Tedious - yes, but until a true fix is available there are not many choices.

Thanks - yes, I added them manually so I could get the file out of the door.