Section names - Restoring the ability to name my own


#1

I turned off the ability to name my sections by choosing don’t show me this again. I could not find in preferences how to restore the ability to name my own sections {like you can with styles). I can do it with Outliner but that is much too cumbersome.
Thanks for the assistance.


#2

To change the name of your section plane using SketchUp Pro Windows application. Please follow the steps below:

Go to SketchUp> “Windows” tab> “Default Tray”> check on √ “Outliner” > then find your “Section name” by right clicking then > “Rename Section Plane”


#3

Thanks Jennifer
I did not give you enough information. I will try again. When you activate the section plane tool and you hover over the plane you would like to create a section for and choose it, you are prompted to either name the Section or give the default name and not see the prompt again. I chose to not see the prompt for naming the section but have since decided that I would like to name my sections. Is there a way to restore this feature?

Thanks

Barry


#4

It is terrible shortcoming of the current version that you can turn the Section-Naming feature OFF, but not back ON !
It should be an option in Preferences… But it’s not.

BUT there is a convoluted way to fix it - at least on Windows…

Close SketchUp.

Find the folder:
C:\Users\YOURUSERNAME\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp
It is hidden by default, but changing Folder>Options to show hidden file, or copy/pasting the [edited] folder-path into a Windows Explorer window address-bar should take you there…

Then find the file named:
SharedPreferences.json

Edit it with a plain-text editor - like Notepad++.

Find the entry that reads:
"ShowSectionToolDlg": false,

Change it to read:
"ShowSectionToolDlg": true,

Save the file.

Restart SketchUp…

The Section-Naming dialog should be restored !

Be careful not to change anything else !
If in doubt - stop.


How to show section plane pop-up window
#5

On Mac it is also in a hidden folder:

Close SketchUp (Right-click on icon in the Dock)

Open Finder. [Go]

Shift+Cmd+G

Type:

~/Library/Application Support/SketchUp 2018/SketchUp/

Find the SharedPreferences.json file and edit it with the texteditor App.

Find the entry that reads:
"ShowSectionToolDlg": false,

Change it to read:
"ShowSectionToolDlg": true,

Save the file.
Restart SketchUp…

The Section-Naming dialog should be restored !

Be careful not to change anything else !
If in doubt - stop.


#6

On Mac you can select a path in any selectable text block, then right-click and choose Services/Show in Finder, to go to that location. Try it on this text:

~/Library/Application Support/SketchUp 2018/SketchUp/


#7

This really should be a check-box in SketchUp > Preferences !
@ChrisFullmer


#8

@TIG, I haven’t changed anything yet and was going through a renamed copy of the file you mentioned to find the setting “ShowSectionToolDlg”: true, just out of curiosity and for later, just in case. But this text isn’t there at all.

Could it be that it isn’t listed at all till you disable showing the pane (= check the yellow box)?
image

Or do I need new specticles?

p.s. I’m on Windows 10


#9

this is true, at least on Mac. So deleting “ShowSectionToolDlg” would suffice.


#10

I think I know what you’re saying but I can’t delete anything that isn’t there yet. :wink:
So once the text has been created and thus set to false you can delete the line “ShowSectionToolDlg”: false altogether and then you are back in business?

p.s. I would rather set it to true b.t.w.


#11

Yes, it does at my system! (Mac)

i am not sure if the order has any effect…
I think @stacy was on it?


#12

Uh?
On what? She hasn’t been “near” this thread?


#13

Every “Do not show me this again” message MUST have a corresponding preference to reset it. This is not very good design at all :frowning: .


#14

no, but I recall that this issue was mentioned before in some other thread were she did take part of.


#15

Yes, this is a known issue that we are aware of in which you can’t reset the dialog from within the UI. We hope to have a fix in an upcoming release.

The setting does not show up on the preferences file until you’ve selected to not show it again.


#16

Thanks Stacy,
As a long time user and fan of the software, I appreciate your honesty and willingness to correct it. Other users have offer the text file edit as a work around but since this is a one time problem specific to this drawing I will use Outliner to rename Sections. I assume since I have not made this change to the Template that I will see the option to name my own sections as usual.


#17

No, you won’t see that option in a new drawing until you change the preference file as mentioned above.


#18

Gordon,

Thanks for the clarification. This definitely makes the issue more pressing.

Barry


#19

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.