Screen goes black for a few seconds!

My Ruby script rather alarmingly makes the screen go black for a few seconds! The script works fine. The screen returns and everything is fine. It just gives me a bit of a fright that it happens. Any ideas what the problem might be. My script is quite a taxing one for the processor.

Same here with a script on my laptop with integrated HD4000 gfx when reducing lots of unnecessary vertices with the ‘removeLonelyVertices’ plugin by Fredo6.

Does anyone know why this happens?

And is it happening to anyone else with anything else?

does your plugin suspend the view when running?

I’m going to hypothesize that your computer has an “integrated” video card which shares memory with the rest of the computer, and that the ruby script is using enough of the memory that the video card is temporarily being starved of resources. Can you share information about the computer & video card you’re running?


My computer is an HP p6785uk Itel Core i5-2300 CPU with 8gb of RAM and Windows 10 64bit OS. It has a display adapter NVIDIA GeForce 405 DAC type = Integrated RAMDAC total available graphics memory 4095mb dedicated video memory 1024mb and shared system memory 3071mb. I guess the shared memory is the issue?

if disabling “Window > Preferences > OpenGL > Use Hardware Acceleration” fixes the display output issue the graphics driver is (likely) the cause (= bad OpenGL support).

You could also try adding a few lines to your script that disable the update of the UI. Look in the online manual for the exact syntax.


thank you for the tips. I will try these out and let you know. It might be an issue affecting other people.

Out of curiosity, have you recently upgraded to Win10?

Yes I have. A few weeks ago.

In that case you have probably broken the connection to you Graphic Card. It seems there is an issue with win 10 and certain nvidia cards. You can change settings on the card and how it should behave with your programs but in reality it doesn’t function.
Go to your Opengl settings and click the details button. I bet it doesn’t show Nvidia as the card.

You are quite right. Sketchup’s OpenGL info box (Window, Preferences, Details) doesn’t show my graphics adapter; it is described as an adapter, not a card, by the Win10 system query report. What a bummer! I might try Nvidia but maybe they don’t support old adapters for Win 10?

If you find an answer let me know as I have a similar issue and have yet to resolve it. I get to choose between seriously jagged lines or a selection box that it a mass of lines.

I thought I had fixed it earlier by disabling my Intel adapter, everything worked perfectly, even showed Nvidia in the details box. Perfect display, smooth lines, correct selection box, bliss.
Reboot. All gone to hell. Multi screen setup is gibberish. Even running a single screen it’s screwed until I re enable the Intel card.
Now in pub solving it with beer.

its midday and already?

is that issue with your surface pro 3?

2.22 am. Here.
Surface pro no. It’s an Hp laptop with twin graphic cards.

whoa, you da boss.

i was getting nervous as I just ordered my surface pro 4.

Good luck!

I would be interested to hear how well the pro 4 performs.

I just downloaded the latest driver for the Nvidia GeForce 405 but to no good effect. Turning off acceleration ‘solves’ the screen going black problem but I suspect at a cost elsewhere. The only good thing is that the screen works as normal after the extension has done its work.

I will contact Nvidia and Microsoft and see what they have to say.