Scenes not working correctly in Layout 2020

I upgraded to Sketchup 2020 Pro the other day and ever since making the switch my scenes don’t switch sometimes.

Any help?

1 Like

Impossible to tell you what’s happening with so little information. Have you got a LayOut file that shows this that you can share?

Did you install SketchUp/LayOut 2020 correctly? That is, did you right click on the downloaded installer and choose Run as administrator?

Not sure if I did install it that way. Should I uninstall?

No but you should close both SketchUp and LayOut and then find the downloaded installer. Right click on it and choose Run as administrator and then when the options appear, choose Repair.

It’s possible that it doesn’t look like you scenes are switching because of the changes we’ve made to LayOut for 2020, particularly how the connection to the SketchUp model works.

Take a look at the Skp model inspector window and look to see if the Camera, Effects, Style, and/or Tags sections have a grey background and a Reset button. If so, you have overridden some or all of those aspects of your model’s scene. You can use the Reset buttons, or the Reset All button to reset some or all of the overrides.

In LayOut 2020, changing the scene no longer resets your overrides. This is different from how 2019 and earlier versions of LayOut worked.

Hope this helps,
Adam

1 Like

As noted we would need to see your file to be sure, but there has been some common confusion around the new options in 2020.

1 Like

Hi Adam,

Thanks for the post. I ‘ve been having serious problems with the scenes. They arent following my model .skp scenes. Also I quiet understand where I can follow up ( my window doesn’t have a grey background ). And also WHY in the hell! would they do that. I liked the way it’ worked in 2019…

I have no idea about the WHY, but many users (me too) have been requesting for years more control of SketchUp views from Layout to reduce the need of jumping back and forth between LayOut and SketchUp. The features introduced with v.2020 are a big step in the right direction.

To work with viewports the same way as in 2019, just remove all the LayOut viewport overrides.

2 Likes

Please provide a sample LO file so we can try to diagnose the issue you are describing.

Thanks
CD

I have run into similar issues and the Reset All function solved the problem. It’s better with 2020, but it’s a learning curve changing old habits.

Hi Adam,

I’m having problems with this as well:
Simple model with no layers
Have sent to layout and copied and pasted into layout
Either way, i open 3 pages for the three scenes, select the scene in the model inspection window, and no matter what I do, only one scene will show at a time on ALL of the Layout pages.

have done as you say, reset all (though I had no clue what a model inspection window was…LOL, what else am I missing??) no change.

I had already ditched the download So… uninstalled and re-installed the program, I chose Run as Administrator, chose repair, and it gives me this error:
(How do I upload a screen shot here???)
Windows style Error says:
The feature you are trying to use is on a network resource that is unavailable.
Click ok to try again, or enter an alternate path to a folder containing the installation package ‘SketuUp2020.msk’ in the box below.

SketchUp 2020 error says: Package SketchUp Error: Error 1706 No Valid source could be found for product SketchUp 2020. The Windows Installer cannot continue - this is blocking the Trimble installation screen with the green progress bar.

I “just” installed this, have opened it, used it. To be clear, I only get these errors when I’m trying to repair the installation.

Thank for any help you can give me.
Judy

This sounds like you’ve placed the viewport on a shared layer in the LayOut document. That would create what you see and no uninstalling and reinstalling would change that behavior.

So the shared layer is the default setting? How do I change that?

No. It’s not a default setting. I’m not sure how I gave you that idea. If the layer you are sticking your viewports on has been set so the content is shared across pages, whatever is on that layer will show up on all pages. Here, for example, is the layers list from one of my templates. The last layer in the list is a shared layer as evidenced by the icon in the far right hand column. In my template that is used for page borders, page numbers and other content that I want to see on every page. My Model layers are for the viewports from the SketchUp model and they are not shared.
Screenshot - 6_29_2020 , 4_55_06 PM

You can change the state of the sharing by clicking on that icon in the right hand column.

Note that you can have content such as your viewports on the same layer throughout the document. If the layer is not shared, those viewports will only show on the page you placed them. In other words, you do not need to make new layers for each page of the document.

I asked if this was the default setting because my drawing has only one layer.

I’m not in my office, I’ll take a look at this tomorrow.
Thanks for the help.

I’m going to guess that this did not install correctly because it won’t run the repair. It says the file is missing.

Though, I did get this to work by selecting each of the scenes, copying them, then pasting them on separate pages. Then changing the style in the SU Model Inspector Window for each page separately.

This means that in the SketchUp Model inspector window, each scene (each on it’s own page) is labeled the same, as Last Saved SketchUp View, not scene 1, 2 etc.

It also does not update, having added detail to the SU model, saved, clicked on update in the Document setup/references. Also clicked on re-link, still no changes to the LO document to match what’s happened in the model.

I used to be able to Send to Layout from Sketchup and bring each scene up using the inspector window. Is there some new way to save that on each page? There are no greyed out command boxes, that’s all working.

As for layers:
Each page has a default layer and an On Every Page layer that applies to my sidebar and logo. Nothing I did here made any different, I tried toggling things on and off.

Thanks for the help. Greatly appreciated.

Hi Judy,

I’m guessing it’s indicating a .msi file is missing?

Have you downloaded the very latest installer from sketchup.com/download/all by any chance? If not, you might try doing that and installing by right clicking on the installer and selecting Run as administrator.

Does this mean you were copying from SketchUp and pasting in LayOut?

Yes. That’s not good and likely to cause big problems if you have some reason to make any edits in the SketchUp file.

No. It’s still the same.

So just the basic template layers? And the model is on the Default layer?