Scenes not updating or saving, wierd bugs


#1

So I am having this wierd issue that I will make some changes and update a scene, click to another scene and come back - and the previous scene is now showing a different scene, or a few of the entities are hidden, or a number of wierd things.

Is it something that I am doing or is the program just unstable?


#2

Have you examined what “save” boxes are checked in the Scenes window for the affected scenes?


#3

The terms, “some changes” and “a number of weird things” are rather vague.
What are you changing?

If the changes involve Style, then you must first update the Active Style or create a new Style.
Then update the Scene.

Tip:
Use the Scene Manager (expanded) to create and update scenes.
Keep the relevant model managers open when creating and updating scenes.

Depending upon what you’re doing those may include…
• Styles Browser - In Model panel
• Layers Manager
• Shadow Settings
• Fog


#4

Ok I will try to be more specific.

I will update a scene and then click on another scene, then come back and it’s showing me a different scene even though I am clicked on the tab for the scene I saved.

Or I unhide some entities and update the scene, and save the whole file. And then when I come back those entities are hidden again.

Please help…


#5

Oh and all the boxes are checked when update the scene.


#6

What changes? What’s different when you come back to the scene?

It would help us help you if you would share the model rather than struggle with vague descriptions.


#7

For the uninitiated, you CAN turn off camera location updating on scenes - that trick escaped me for a while. The only trick I could see: if I’m on scene 1, it’s highlighted, but I right click just on the border of it on scene 2, what happens? I don’t update the scene that’s highlighted (scene 1); I’m updating scene 2.

In the same way, I can have scene 1 as the current, active scene, but have scene 2 as the current scene in the Scene Panel, and clicking update in the Scene Panel will update scene 2, not scene 1 (as noted by the pencil in the Scene Panel).


#8

Thanks Barry! That did seem to help.

Also instead of selecting multiple objects / entities and right clicking “unhide” I ended up going one by one in the Entity Info box and selecting unhide for each one. That seemed to work. Not sure how they got hidden in the first place :frowning: