Scenes & Cameras won't delete

I have tried deleting cameras and scenes (and the tags associated with them) yet when I close the file and re-open, they return. Does anyone know what I’m doing wrong?

What do you mean by deleting cameras?

Are you saving the file hafter deleting the scenes and tags? Perhaps you could share the .skp file with us so we can see what you’ve got.

Thank you for your reply Dave.
I’m unable to share the file as it is part of a project with limited public access at this stage of its development.
I’ve had this problem before, especially with scenes that were created with cameras.
I have 12 or so scenes.
I’m sharing file with partners to focus on 4 of them.
I deleted the cameras for 8.
I deleted the tag “cameras”
I deleted the scenes associated with the 8 we won’t use.
I purged the file.
I fixed errors (there were none).
I saved the file.
I closed the file.
Then sent it to my partners and all 12 scenes were back! Crazy…
Tried it again on my computer and checked before I re-sent them and same thing…
Must be a glitch of some sort, so I’m hoping for a work-around.

are you able to delete the content of your file but keep the scenes, so you can share it ?

Are you certain you are sending the file you just modified? You aren’t working on a backup file are you?

On a MAC backup file is named xxx~.skp when the main model is named xxx.skp
A PC uses .skb files as backups of .skp files

Certain about the file and that it is not the back up file (back up file has the “~” correct?).
I checked date and time modified in Finder before I re-opened it and poof, all scenes were back…

Without seeing what you are working with all we can do is guess. I expect there’s something missing in your process but no way to identify it with certainty with so little information.

You keep mentioning “cameras” - plural. SketchUp has only one camera, though it can be positioned differently in each scene. Is that what you mean? But the Advanced Camera Tools simulate multiple cameras. Are you using the Advanced Camera Tools extension?

Yes. I used Advanced Camera Tools to set up multiple cameras that resulted in multiple scenes. Good for telling many stories about the project from different vantage points that can be developed as we develop the project.
See screen shots.
Just tried deleting again.
Did a “save as” and changed the file name.
Scenes still returned.
They’re like gremlins!

See screenshot of what I’m trying to reduce to:

Did you reset the camera in the Advanced Camera Tools?

Deleting a layer / tag does NOT remove its associated objects, unless you specifically tell it to do so.
So if you have object “CameraX” assign to layer / tag named “Camera” and you delete that layer / tag, then “CameraX” is probably using “Layer0” / “Untagged” - so it’s no really ‘gone’ at all…

Thanks TIG.
First I physically selected and deleted each camera from the model.
Then I deleted the tag that they were on and specifically clicked that button to delete all objects associated with the tag.
It seems scenes just won’t go away.
I just picked one of the scenes, reset the camera, then deleted the scene. saved and closed the file. when I re-opened, it was at the back of the scene list.
Seems crazy to be so deliberate and they won’t go away…

Sounds to me like the Advanced Camera Toolset is redoing everything again when you restart SketchUp ?
As Dave said, have you tried to reset things within that ACTool ?

After doing all of your deletions etc have you tried disabling the ACTool in the Extension Manager, then saving and restarting SketchUp to see if that helped ?

I’m sure you should be able to unset the ACTool’s Cameras etc…

Thank you gentlemen.
You gave me a few places to look and I’ll follow up if I get it fixed.
Working around the issue for now to keep on schedule.

I am having the same issue. Have you found a fix for it? Thanks!

Did you try resetting the camera in Advanced Camera Tools?

Share the .skp file so we can see what you’ve got.

I am not sure what I did, but I fixed it. I am new at Sketchup. I zoomed out, deleted cameras and deleted scenes on the scene tray and the scene tabs. One of those things worked, or maybe it was the combo. The old, unwanted scenes are gone. I will do a more measured process next time to figure out what actually worked.

Thanks for the quick response.


Deleting the scenes would have taken care of it although it’s a little like burning the house down because it’s painted the wrong color. If the scenes were showing the gray bars you could reset the camera for that scene and then right click on the scene tab and choose Update. Normally the Camera settings are a property of the scene. You can revise that any time you like by updating the scene after making the changes.