Scenes and layers keep messing up


#1

Hello. I’m hoping to get some help with an issue that I just started having. I have created a cornhole board mockup for some christmas gifts with three scenes. 1 - Mock up is the completed board with graphics. 2 - Cut list is a cutting layout for the boards with dimensions. 3 - Leg Detail is just that, leg details with dimensions.

I also created three layers to match and assigned the appropriate components to the right layer so I can turn the others off when switching scenes. I also the axis turned off.

When switching back and forth between scenes 2 and 3 it works fine. But if I select the Mock Up scene, then go to scene 2 or 3, the mock up layer ALWAYS remains checked as visible in the layers panel. I have unchecked it and updated the scenes many times. And I checked my scenes panel to make sure nothing seems off there. All boxes are checked. But no matter what I do, the mock up scene always comes back. It’s like once I activate it, it remains always visible.

Is there something I’ve missed? I’ve never had this problem before. I’m a new sketchup user but have done several woodworking projects with scenes and never ran into this before.

Thanks!


#2

It would be a whole lot easier to help you fix the problem with the SKP file to look at. Could you post it? Or, if you don’t want to post it publicly, send it via a private message.


#3

Well, I can’t figure out how to attach files, or even how to PM you. Is there a delay on those things? I just registered today.

Anyhow, here’s the skp file.

https://copy.com/gnTw6RuDiSQwSKQo

I’m sure there’s a more efficient way of doing what I’ve done, but I’ve only been using the program for a couple of weeks now.

Also, I have an issue with importing images to the faces as well. But, I figured out a workaround to it, so it’s not a huge deal. For some reason, when I import an image to side rails, it seems to want to put the image behind the actual faces but on the same “plane” as they are. If that makes any sense whatsoever. If it helps, I can re-create what I’m seeing there and re-upload it. But one problem at a time…


#4

Change the Active layer back to Layer0

There is almost no reason to ever change the active layer button. Keep it on Layer0 until such time as you know you need to change it.
Just to be clear, I mean the little dot to the left of the layer name. Always on layer0.


#5

Well I’ll be dipped. That did it. Had no idea I had clicked off the Layer 0 as the active layer. Explain like I’m 5 - why did it matter that I had done that? What does that change to cause the symptoms I was seeing?

As for my other issue, related to importing textures, or, in my case, an image to place on a rail. For some reason it’s placing the image on the same “plane” but behind the actual face. Updated file is shown below. I have a workaround for this, but it’s a nuisance. I know it’s not really related to the first issue, but any advice on it? Or should I make a new topic for this?

https://copy.com/gnTw6RuDiSQwSKQo


#6

You cannot switch off the active layer. SketchUp should pop up a warning box to inform you if you try this, but it also has a “Do not prompt in the future” checkbox that may have gotten checked.


#7

That’s what happens when typing away on a phone, Dan gets in quicker, but written so will post.

Put simply, you can’t hide the active layer, so if you have a scene set to hide a layer then make that the active layer it will do strange things.
So as a general rule, always keep layer0 active and visible. Always keep raw geometry on Layer0 and assign Groups and Components a visibility layer. The geometry on layer0 will be hidden without hiding layer0 as long as it is wrapped in a group or component that has been assigned another layer.

As to the other, I’m on my phone so can’t look at your image problem. But at a guess, it sounds like you should be importing the image as a material and painting it on a face. Rather than importing as an image and placing it on a face. Check the import dialog for the options.

As to uploading or attaching, the icon seventh from the left at the top of the message window is the upload button. A bar with an arrow pointing up.