Apparent Malfunction of Scenes

I have drawn a desk I am planning to make. I drew it on layer zero. Everything is a drawn as a component. The drawers, which consist of several components, are set up as groups of components. When I finished drawing, I assigned different parts of the desk to new layers. For example, I created a Leg layer and then assigned the legs to that layer. Similarly, I made other layers, such as Panels, Top, Rails, Drawers, Drawer supports, Blades, and Fillers. I then assign the respected items to their respective layers. When I finished nothing was left on layer zero. Ok, now I started to develop scenes. The first one, an overall perspective of the desk, has all layers visible. Next I created a scene to show just the top. I make the Top layer the active layer, made all of the layers except the top layer non-visible, updated the scene. To check I went back to the first scene and it was good and then back to the top scene and it just showed the top like it was supposed to show. Then I added a new scenes to just show the legs, made the leg layer the active layer and all other layers none visible and update. To check I went back to the top scene but now SketchUp changed the active layer to the leg layer and included the legs in the top scene. I again made the top the active layer, made the leg layer invisible and updated the scene. I went to the Leg layer and it was okay but when I went back to the Top layer, it again should the leg and had the Leg layer active. Why is SketchUp behaving this way? I am using Sketch-Up 2017, the latest update, and am on a Mac with OS X Sierra 10.12.6.

Any chance you can upload the SKP file so we can see what you’ve got. I expect there’s a simple fix but seeing the SketchUp file would make it easier to confirm.

I tried but it’s not letting my attach it. It says it’s too big. File size is 4.5 MB. Any suggestions

First thing would be to go to Window>Model Info>Statistics and choose Purge Unused. Save it again and see if you’ve got the file size down to 3 Mb or less. If not, upload it to the 3D Warehouse and share the link.

1 Like

You can always upload to 3D Warehouse and share a link here.

EDIT… @Daver beat me, again!

1 Like

I did the purge but the file size stayed the same. I’ll try uploading to the 3D Warehouse. Any tricks for that move?

1 Like

You need to sign up for an account (free) and log in through SketchUp. Then you can upload directly from the Warehouse toolbar or use File>Warehouse>Share Model.

I uploaded it. It’s called Desk for Morning Room

I’ll look.

Got it. No scenes, though. Maybe that’s a 3D Warehouse thing. I’ll play with it and see what I get.

I’m happy to see your long wood grain textures.

I follow your and Tim’s Blog on FWW.

1 Like

The active layer should not change unless you change it. It should always be Layer 0. The visible layers could/should change from scene to scene but the active layer should not.

Is it possible you changed which layers were displayed–turned off the top and turned on the legs and then updated the Top scene?

Look in the Scenes window. Do you have all of the boxes for Propeties to save checked?

Or is it possible you’re only highlighting the scenes in the Scenes window but not actually switching scenes? To switch scenes you have to either click on the scene tab at the top of the model space or double click on the scene name in the list in the Scenes window.

What I have for Scene 1, all layers visible and the active layer is Layer 0, for scene 2 only the Top layer is visible and active. Layer 0 is non-visible. For scene 3, only the Leg layer is visible and active, all other layers including layer 0 is non-visible. When I return from scene 3 to scene 2, SketchUp changes the active layer to the Leg layer and has both the Top and Leg layer visible. All property boxes are checked when I do the update.

I have tried updating the scene tab and the scene listed on the scene window. I selected it and used the update symbol at the top of the scene window.

You should leave Layer 0 active and visible at all times in all scenes. Just don’t touch that one.

The active layer is not a scene property to save. It remains as you have last set it.

So for the Top scene, leave Layer 0 and the Top layer visible. Untick all the rest. For the Leg scene, untick the Top layer and check the box for the Legs layer. Leave Layer 0 active and visible in both cases.

1 Like

Thanks Dave. I think that corrected my problem. I didn’t realize that Layer 0 remained active. Thanks for you excellent help and attention. Cheers

You’re quite welcome.

You want to leave Layer 0 active at all times as this prevents you from inadvertently putting edges and faces on some other layer. With it always active, you don’t have to worry about those mistakes.

Nice desk more, by the way.

To add a bit of explanation to what DaveR said. If you turn off the visibility of Layer0, all your faces and edges on Layer0 will become invisible - so you won’t see ANY components or groups on the supposed-to-be visible component or group layers.

And you should ALWAYS, as he says, put edges and faces on Layer0, AND leave it permanently ‘on’ and with its radio button ticked as the Active layer.

(There are very rare exceptions to this, but you need to really know why you might be doing something else, otherwise you will baffle yourelf with weird behaviour in the model).

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.