Can't remove a layer from a scene?


#1

I just started working with layers and scenes and I was having a little trouble figuring it all out so I thought I would try a simple test project. The object is to play through four scenes 1. square 2. circle. 3. hexagon 4. All of the above. I got everything to work fine except I cannot hide the square layer from the other scene. I must be missing something… Here’s a short video on what I’m doing maybe someone can point out a different or better way. Thanks again. https://www.youtube.com/watch?v=AkvOACnVuMY&feature=youtu.be


#2

Hi,

Okay, I can’t fully explain the why of all this. . . but I think I know what the problem is,. . . or at the very least I can make the animation your trying to make without the problems you’ve run into.

I think the main difference between what I did and what you did, is in how we handle layers differently. For my attempt I took the following approach. . .

— I drew ALL of the objects on Layer 0, initially.
— After that I created the 3 extra layers. . . ‘square’, ‘circle’, and ‘hex’.
— Then I selected each shape in turn and assigned it to it’s own layer via the ‘Entity Info’ panel which has a pull down menu that lets you change an objects layer affiliation.

. . . After all that I set up up each scene, and adjusted it’s visibility state from the layers window. BUT, I’m still working in Layer 0 during all of this time… and at no point have I set any of the other layers to act as the active/current layer.

I think the basic problem you’re getting into is that the status of the current layer keeps moving amongst the different available layers.

. . . and this is the point where I can’t explain why this is a problem. . . but In general it’s my understanding that it’s best to always draw in layer 0, and then move object off of that layer and onto something else by using the ‘Entity Info’ panel.

I never changed the current/active layer, to something other than layer 0. I just reassigned the layer affiliation of my shapes when needed (via Entity Info panel). Based on what I can see in your video your current layer keeps bouncing around between the different available options. . . which in SketchUp is a bit risky. But unfortunately for reasons I can’t explain.

I’m sure others will have a more informed opinion on what’s going on here. and I’ll be happy to read about it.

Take Care,

Jim


Edit:

Sorry about my original typo where I referenced ‘edit info’, instead of ‘entity info’ – which I’ve since changed.


#3

I only outlined a difference in methodology in my first comment.

Rather than recreating everything from scratch — Perhaps you can set everything straight by setting layer 0 as the active/current layer prior to doing the scene updates which you were doing.

Didn’t try this out myself, but it seems reasonable. so. . . Good Luck, I hope.

Jim


#4

Well I just did a far more complex project with the layout and scenes and it worked perfectly fine, which almost leads me to believe that i’ve come across some hidden data in the square scene that would not allow me to turn it off. The program thinks every scene is the square seen for some reason even when i’m on the hex or circle it will not allow me to change the square layer. Its a bit perplexing. haha


#5

Did you not read anything Jim said.
He was right on point, you are using layers incorrectly.
You have obviously turned off one of the warning dialogs that tells you can’t hide the active layer. Each time you make the Square active and try to hide it it won’t let you.
Are the shapes raw geometry, as in just edges not made into groups or components?
Never put raw geometry on any layer other than Layer0, never change the active layer from Layer0, basically, never move the dot on the left of the Layers dialog away from layer0. There are very rare occasions where you would but not here.
Draw your shapes, make each one a group or component and assign it a layer. So when you select the group it shows a it’s layer in the entity info window, but when you open the group for editing and select an edge inside, the Entity info will tell you it is an edge on Layer0.
Layers only control visibility, groups and components separate geometry.


#6

Before delving into the use of Layers in SketchUp you must first understand Groups and Components.

I’d recommend these learning resources:
Does SketchUp support layers? — SketchUp Help Article w/Video


Components


Scenes


Create and edit Scenes via the Scenes Manager in conjunction with the relevant model managers.
• Entity Info
• Styles
• Layers
• Shadow Settings
• Fog
A visit to the Help Center to learn more about these is time well spent.


#7

Looks like I’ve got some studying to do. I’ve just been figuring it out on my own over the last few days so I didn’t have much insight on the order in which to learn things. Thanks a lot guys!


#8

I’m sure my error posting a link to the Photo Match video vs the intended Scenes video, didn’t help.
All fixed. Sorry if that added to the confusion.

If you enjoy learning from the videos here’s a good place to start.
SketchUp Video Tutorials — Training Series Playlist