Scan essentials not working, point cloud invisible

Hi, I’ve installed SketchUp studio 2023 and the newest scan essentials and have tried everything bing’s AI could point me to to fix the problem but…
The point clouds just don’t show.
After loading the import there is nothing.
Except when I press the extent zoom button it does zoom out as if there is something.
The weird thing is, I first tried all the point cloud file types there were and then… Them I went on to try Trimble example scan essential files.
Nothing is visible after loading no matter what I try.

I have windows 11pro, 32gb ram, 12 threads, 28 cores at 3 something GHz and a AMD Radeon 6800 XT beast of a graphics card. Even updated all the drivers for that one after encountering the problem but to no avail.
OpenGL 4.6 is there and running.
Tried all in extension settings but Nada.

I’m fresh out of ideas. Reinstalled SketchUp as well as scan essentials, even the layout plugin for it, nothing helped so far.

Does anyone maybe know something else I might be able to try? It would be very much appreciated :pray::pray:

1 Like

What settings do you have?

This is in SketchUp 2022 with sample data from SketchUp Scan Essentials - Liberty_Bell_Dolores_Park.rwp


Hi Daniel,

As mentioned by mihai.s, can you see the settings in the Point Cloud manager?
Can you “snap to the point cloud” with the Rectangle tool (if it is a display issue you may see inference points: From Point should be written)?


I have these settings, just downloaded that example model also but same problem persists.

I can see a box around something invisible with that yes. But the “snap to the point cloud” is a bit unclear for me since I have never been able to use the software before - this is my first attempt of trying to make it work.
What would this box tell you? The point clouds do load in autodesk, twinmotion, blender etc.


It’s a clipping box

Maybe that box is in an area where there is no point cloud.

ah thanks, I meant more about the problem I’m facing, that the box is there but the content isn’t. :slight_smile:
I was hoping that the symptom could provide more insight in the underlying cause and solution to it.

As I said, what settings do you really have?

Basically the stock standard ones, I tried clicking them all and moving everything to see if anything would appear but nothing did.

What’s the name of the file are you trying to open? What extension? How many megabytes does it have?

I tried your Liberty_Bell_Dolores_Park.rwp one and then some random other ones, all files have been between 75 and 150 megabytes.
The files do open op undet but I would like to use scan essentials instead.

Do you have any hidden section in your model?

Maybe it’s not related, but how come you don’t have any style in the panel window?

Probably because there isn’t a model in the model, it’s just the example point cloud that I’m trying to open so there is nothing to style. I can select a style if I want.
But no hidden section no, even when I turn on show hidden object or geometry, or even unhide all, nothing is there.

Have you tried shutting down and restarting your computer, then load again the .rwp file?

I asked because even without any geometry in the model, at least one style appears in the panel.

Yes I have tried that, I’ve also tried going down a couple of drivers for my GPU to the pro content creator edition and I’ve tried setting it to a style. I’ve tried sketchup 2022, 2023 and the problem still persists.
It does all work fine on my lower end laptop but I need it to work on this beast of a pc.

I have exactly the same problem.

Im running Windows emmulator in Parallels on a new MacBook Pro.

Sorry me again. To clarify:
Im running SketchupStudio Trial on a virtual PC in a trial of Parallels.
All running, as I said, on a Mac Book Pro.
This is a test to see how we can work form Point Cloud scans into Sketchup.

Hey BananaSplit,

this is not the same issue. Tsolsi told me he updated all the chipsets of his PC and that Scan Essentials is now working.

Regarding your issue: we do not officially support Parallels. However Scan Essentials should run on BootCamp.


1 Like

Thanks Jaques - Ill try a Bootcamp trial.
We have an old PC in the office, and the software is working fine, only on the Virtual PC it doesn’t.

I note your comments re Tsolsi - However the description he gave is identical to mine - See screen shot.

I am having the same issue as described in this thread. I have a Ryzen 7 5800X and an RX6600.
My workmate is able to open and view point clouds, but i am not, even if he opens them first and checks that it loads and then saves it. When i try to open the file i see nothing. His system has an Nvidia mobile GPU.
I wonder if AMD GPUs are not supported for scan essentials?