Scan essentials not working, point cloud invisible

What does a checkup report say … SketchUp Checkup | SketchUp Help ?

I did a checkup report and it said all was good.
I’ve attached the log file also.
SketchUpLog.sulog (141.4 KB)

The software doesn’t even really know what type of GPU you have - but AMD drivers are notoriously finicky.

Make sure you have the very latest drivers installed from the AMD website NOT from Windows update

I updated my drivers yesterday from the AMD website, using the specific installer for my GPU.
I tried the same file on another workmates PC who also has an AMD GPU and got the same issue.

Can you post a dxdiag report?

Having same issue as Tsolsi and matt15.

I’m running an AMD RX6600 and Sketchup 2023.

The current AMD RX6600 drivers are v23.5, and the AMD website has older versions down to 22.9.

Unfortunately, it looks like I have to downgrade the drivers to 22.5 in order for Scan Essentials to display the point cloud correctly.

DxDiag.txt (86.3 KB)


All looks fairly normal - you might want to try and see if you have a bios update you can do - I can’t find one that matches the ones listed in that report.

A new one was released a couple of weeks ago - a few of the releases have GPU related fixes.
MSI MPG B550 GAMING PLUS AMD AM4 DDR4 M.2 USB 3.2 Gen 2 HDMI ATX Gaming Motherboard

It may well just be driver related if other users find they have to downgrade

If the file name is too long then the Cloud fails silently.

Just getting back about this issue. I tried a BIOS update which had no effect.
I was able to borrow an RTX3080 off a friend to try and once i installed that and the relevant drivers the point cloud worked immediately as it should.
I believe the issue is either with sketchup compatibility with AMD GPUs or an AMD driver issue.

I’m most likely just going to have to switch GPU brands to resolve this.

Sorry, just realized I never replied- nothing looked untoward there and on paper everything was ok

AMD drivers are pretty shonky sometimes, they’ve always had a poor reputation, so maybe not a bad idead.
I spent 4 hours with a user last week who was having all kinds of weird stuff with theirs for Enscape/SketchUp/VR Headsets.
There was a whole bunch of absolutely weird and inexplicable stuff I’ve never seen before.

I ended up using DDU Display Driver Uninstaller Download version (

to clear out all signs of AMD/nvidia/intel drivers from the machine - there is an option to prevent it searching Windows update on reboot.
I then installed the latest Driver only package from AMD (which had been installed before!) and it the entire behavior of the machine changed and it worked fine.

Maybe give DDU a go