Scan Essentials E57 import fails - project does not contain any points

can anyone help with this, please?

I’m trying to import an E57 file using Scan Essentials and keep encountering a problem. It gets about 20 minutes into the process and fails, saying “this project does not contain any points. Please extract points in Trimble RealWorks and try again.”

I’m pretty sure there a few points in that file, probably 50 million or something, so it’s frustrating to be told there are none.

Anyone got any ideas?

Sketchup Pro 2021, Version 21.1.332 64-bit
Windows 10 Pro, 16GB RAM

Can you provide a link to the file?

1 Like

Hi Mike,

thank you for your reply. I can’t provide a link easily! It’s from a surveyor, and is a 47GB file, so not super easy to transmit! I went to their offices armed with an external SSD. (I want to establish that I can use their data files before commissioning them to do a large survey, this is another project they’ve done)

I have tried some other sample E57 files I found online: They normally load okay, though once or twice I got the same error. I wondered if it was to do with the template I was using, but apparently not. I can’t reliably replicate the error.

If I can figure out a way to put the huge file online, I will, but in the meantime… anything else you might suggest, please?

1 Like

I should add - don’t be confused the Mac info in my profile! I’m using a Windows laptop to try this, as there is no Mac Scan Essentials extension yet, it seems.

Maybe ask for smaller portions or lower density to see it that works
16Gb ram might not be sufficient…
I would suggest at least an evenly amount of Ram as the file you are trying to open.

Okay, I’ll give ask what they can provide.
It seems odd that if the problem is too many points, the error comes up as there aren’t any points!

Is this how people would manage it? My understanding is that may E57 files are of this sort of size, and few computers are sporting 64GB of RAM.

Raw 3D scans may be unnecessarily dense. There are applications like Autodesk ReCap that can create cropped and reduced versions of point clouds. The last time I needed to do that the original was so dense that you could almost make out the make of the ballpoint pen someone had dropped on the ground in front of the building.

When I talked some years ago with people who were dealing full time with point clouds they had computers with something like 128 or 256 GB of RAM.

1 Like

Hello again.

The survey is done, the point cloud created.
The E57 file is just shy of 20GB. It will not import into the computer with 16GB RAM.

I’ve tried a couple of the individual E57 files from the survey, and they work fine. But the aggregate file is a no. “No points”. Well, there’s nearly a billion, actually!

Is it likely to be just a RAM thing?
Is it pretty much as simple as RAM > file size, probably okay?

Any other options for me?

The surveyor is kindly looking at chopping up the point cloud for me; say it’s two 10GB files, do we think that will work on aThinkpad X1 carbon with 16GB RAM?

Thank you for guidance!

Importing two 10GB files should work. Nevertheless the error message “project does not contain any points” is obviously wrong. I will investigate the issue.
Sharing your point cloud could help.



Thanks, I’ll see about the 10GB files. I can only import one at a time, correct? So I cannot have the whole property as a point cloud in one model in Sketchup?

You can import multiple files with the multi selection (Ctrl or Shift keys).


Hi Jaques,

I’ve successfully imported more than one file. But… the whole point cloud consists of 113 individual files. And it won’t import them. Just doesn’t even try. No error message, just doesn’t do anything. The maximum I could import was 17 files together.

I have also tried on a brand new, fast computer with no other software, no files being store, fast SSD, and 32GB of RAM. Not much better, only 20 files.

This computer also wouldn’t import the 19GB complete point cloud, which surprised me. More of the same error message, saying there are no points in the file.

The surveyor has kindly said he will split the point cloud in two. I sincerely hope this works, as I’m getting pretty frustrated with this! If the error messages were at least helpful, it would be helpful.

What is the overall size of your 113 files?
I don’t know about Scan Essentials, but years ago I talked with people who work full time with point clouds, and they had 128 or 256 GB RAM in their computers.

All 113 files total 18.2GB.

I’ve been trying in small batches, for example 5, between 16 and 200MB each. They load okay, but then become unresponsive. Can’t zoom, pan, rotate. Can select different tools, but they don’t work either. Can’t draw lines etc.

Importing just one file, 112MB in size, seems to work. But this is, of course, pretty useless as a tool.

Importing 3 files, totalling 800MB works… for a while. Before the same stoppage of functionality occurs, requiring a restart.

At this point, Task Manager reports that Sketchup is using 2.7GB RAM, while the system has 24.2GB free.

As said, this on a new computer, up to date (Windows 11), only other software installed (not not running) is Office and Acrobat Reader. And some AV.

Surely this is the best scenario, right? Where on earth do I go from here?


Could you share your files? A small batch could help.


Hi Jaques,

thank you, I have sent you a pm with a link.

Happy to send it to others for help too, if anyone thinks they’ve got a magic want to fix it!


I often import point cloud files that size but I use a plugin called Undet. You can download a free trial at SketchUp point cloud plugin to create 3D models from scan data | Undet

Feel free to ask any questions if you try using it.

Or if you upload your e57 file to dropbox or OneDrive and post or pm a link I will try and import it.

Best of luck.

Hi Kevin,

thank you for your input. I have started the Undet process previously, but I’m put off by the ongoing cost, to be honest. At 600 euros a year, it’s massively more than a sketchup subscription. And maddening to have to buy that if Trimble are producing a plugin to do it, but it just doesn’t work properly.

I’ll pm you a link to my files.

If you are successful, I would be interested, please, to know the spec of the computer you’re running it on.

Thank you!

No worries.

I will download your files, try and import them and let you know how I get on.

As an aside, in case you didn’t know, Undet do offer a monthly subscription for 89 euros if you only need their plugin occasionally.

Are all 114 point clouds based on the same coordinates?

I noticed an issue when the path is too long and when multiple files are selected. I will fix it ASAP.

I will also upload the full project converted to rwp so that you can try to model.


1 Like