Importing with Scan Essentials

Our office just begun using the Trimble X7 and sketchup to process scans of existing buildings into as-built drawings for us to then create plans for additions and remodels. I have been having an issue with importing these scans into sketchup. We have about 50 scans of our project and I exported them from the X7 into e57 files. When I try to load all of the scans into sketchup, it doesn’t do anything and just shows the sketchup screen. When I load fewer scans it asks me to save an RWI file. I am able to load about 15-20 scans at once but not any more than that. Is there a fix to that or is that a limitation of sketchup?

Rachel

I think it’s more of a limitation of Scan Essentials. We also use the X7 and recently had a building scan with 160 stations. When trying to load it, SU asked me to save it as a rwi, which I did and it took awhile but did save a rwi however when I opened it, SU said there were no points in it. Take a look at Undet, it handles large point clouds SketchUp point cloud plugin to create 3D models from scan data | Undet There’s pros and cons to both Scan Essentials and Undet.

I have already requested a trial of Undet but I’m not sure one is available. My problem is a bit different than yours. Sketchup doesnt even ask me to save them as an RWI file when I try to load 20+ scans. It seems like it simply exits the process altogether.

However I can load 15-20 scans, save as RWI. Repeat the process and then load multiple RWI files and everything shows up perfectly. Although when I close the file and reopen it, it will then only load the first RWI so I have to unlink it and reload all of them again. That is my work around, but I previously found another post that seems to suggest there is a problem with multiple files so I’m hoping there is a solution: Scan Essentials E57 import fails - project does not contain any points - #40 by Bagpuss

Specifically there was a reply on Mar 10 stating: Hi,

As I said I found an issue when the path is too long and when multiple files (like 100+ files) are selected.
I fixed it on the beta build. We will release a patch in the coming days.

Jacques"

Hi Rachel,

I can give you access to a beta build which could help you. If you are interested, send me a PM with your email.
Same for @alpro.
Also feel free to share your data and we will investigate.

Jacques

I would like to try the beta build and if there are still issues I’d be happy to send you a link to the files. Just seems to be issues with larger projects which most of ours are 60-200 scan stations. And of course no issues in TBC just find it faster to model in SU.

Could you send me a PM with your email @alpro ?

Dear Alpro,
We indeed needs to go through that loading issue in SE, but as you obviously are a TBC user, I maybe have a trick to propose :
When you save a TBC project including pointcloud data (either coming from TP) you will have the following *.vce file (for TBC) and an associated folder having the name of the project :
2022-10-06_10h52_19

In that folder (FMGeorefTest for me) you will find a SdeDatabase.sdb file and a SdeDatabse.rwi folder
2022-10-06_10h53_33

These 2 objects are actually the same as a RealWorks project, which is the format also used by Scan Essentials to open pointclouds. This is just a bit hidden in TBC for safety purposes.
What you can do is to grap these 2 objects and rename the “SdeDatabase.sdb” into “SdeDatabase.rwp”.
At this point you can just start SU and using SE, open that “SdeDatabase.rwp” to load the full pointcloud as it is in TBC.
The other interesting thing about using the TBC project, is that you will recover all existing segmentation, regions, classification done in TBC, in the SE pointcloud manager

This is not solving the issue of SE but can be a workaround for you.

Regards

Just few more comments about that workflow :
1- I would not use directly the project lying in the TBC folder, but a copy of it : firts because it needs to be renamed (which is breaking the link to the TBC project) and also because some changes could affect the TBC project in a way that you don’t want
2- If the TBC project is in a coordinate system which is far away from the origin (Georef), SE will propose to change it while importing, and be able to display it properly : This means that a model in SU will not be in the same coordinate system as it is in TBC. Note this coordinate change is affecting the “RWP” project and is a reason why we want to use a copy of it and not the original *.sdb in the TBC project
3- this is a workaround/trick, which is actually not intended first. But if you want to experiment, I’ll be happy to have your feedback, and maybe got some ideas to make such a workflow a bit more smooth : especially regarding the coordinates issues that could happen.

Regards

Yannick, thanks for the TBC trick, worked perfectly, no issues loading so it appears that the breakdown is in SU trying to save a rwi. I’ll report back as I work through this model but I can say it’s also nice to have the regions that were setup in TBC.

1 Like

Hi Alpro,

Could you try to open your e57 project with the latest version of Scan Essentials and let us know if it solves the issue.

Jacques