Scaling background image problem

import

#1

Hi, I’m having difficulty resizing (scaling ?) an image, without also scaling the rest of the model.
I have a very basic ground floor layout of an existing building, all accurately drawn to scale. Because the intended works involve the adjacent public road, I imported an Ordinance Survey map of the area to use as a background site plan, the road and the outline of the building being clearly shown.
Having imported the OS Map, I traced the various field/road boundaries using freehand tool, the road is shown as a separate polygon. I’ve saved this as a Group, and saved it to a unique layer. I’ve also saved the ground-floor layout as a separate group, also to a unique layer.
When I show just the map layer, click on group, and re-scale, it works just fine; except that when I reveal the other layer, that has also been resized. I’ve then tried vice versa and re-scaled the project, but when I look, the OS map has also been re-scaled ?
My intention once I have them both to the appropriate scale is to overlay the ground floor layout, orientated exactly over the OS building outline.
I also note that despite having grouped the OS map, when I switch layers, everything is hidden/revealed except the roadway up the middle. Why is this not included within the overall map group ?
I’ve looked at various posts and video’s, and all say that what I’ve done should work, but I’m obviously missing some important step ?
Can anyone point me in the right direction ?


#2

Cut/paste-in-place your background image to a separate SketchUp file. This should be the only thing in the new .skp file. Now scale it as needed. Once the appropriate size is attained, copy and paste-in-place the resized image to the original SU file.

Because the size of the original image will have changed, you will need to adjust the final placement of the image, so it should be placed on its own unique layer.


#3

If it is a Group you intend to resize, you can scale just that Group with the Tape Measure Tool without affecting the rest of the model scale. You need to open the Group for editing before the resize attempt. You will then get a “are you sure you want to resize the active Group/Component” prompt.

On the other hand, if it’s just a plain image resize without affecting the rest of the model, you can do that too. Explode the image then make it a Group/Component. Open it for editing and do the resize with the Tape Measure Tool.


#4

Layers do not separate geometry. Groups and components do.
To resize some geometry (with the ‘Tape Measure’ tool) you affect the entire level that geometry is in and that you are working in, despite what is invisible by layers that have been turned off.
To resize part of your geometry, it has to be grouped and you’ll need to be inside that group, just like @IanT said.


#5

Thank you both, tried both, eventually got there with copy & paste, but then wouldn’t resize imported components, which promptly disappeared from the sketch. So scrapped the lot and started again from scratch, i.e. with importing the background, re-scaling it, and then building the model on top in a separate layer - seems to be going OK- just frustrating having to do it all over again !


#6

The phrase, “building the model on top in a separate layer” leads me to believe you don’t understand how layers work in SketchUp.

Watching fifteen minutes of tutorials may well save you hours of frustration.

Layers


Components


#7

Thank you. I believed that I was inside the group, having set up separate groups , as well as separate layers. I can only think that I was not actually “inside” the group as I was trying to re-size (though I beleived that I was)?

you affect the entire “level” that geometry is in - I wasn’t aware that there was another sub-division of “Levels”, i thought that’s what “Layers” were ?


#8

Thank you, you’re almost certainly correct. I had looked at lots of Posts and Video’s explaining what I was trying to achieve, but obviously was still missing some key point. Though I’ve solved the immediate issue, I’ll look at your links as well, and perhaps I’ll be better able to cope next time. I appreciate your help.

Regards


#9

Thank you Ian, I can only think that I was not actually “inside” the Group when editing, though I beleived I was, and I certainly didn’t ever see the prompt that you quote. I’ve been sent some links to hopefully better explanations, so I’ll maybe work out where I went wrong!


#10

You will get a prompt in both cases with the Tape Measure Tool, it will ask if you are sure you want to resize the model or the active group/component depending on the context you are currently in.


#11

Yes, I was getting the former, which again would imply that I wasn’t actually editing inside the Group ?


#12

I would think so yes. Again, be sure to know that Layers in SketchUp only control visibility and do not separate geometry as in other cad programs. See the video from Geo above.