Scaled model that was imported no longer scaled

To re-produce this problem:

First, start a new skp file.
Then I create a model, say a 1x1x1m cube, then scale it down to 1cm, save and close.

Next I create another new skp file.
Then I create a model, say a 1x1x1cm cube. Now … import the the file that you created above. You will see the size is the original 1x1x1m cube and not the scaled size.

How can I make sure that the scaled object in the first file retains its new size?

Thanks to anyone who has suggestions.

I’m going to guess that you made the first one a Component, if that is the case it will import at it’s original scale.
If you want the Component to permanently take on the new size, right click on it and choose, Scale Definition.

1 Like

Before you save the SKP file of the first cube, right click on the cube and choose Scale Definition. Or open the component before scaling it in the first place.

Scaling a component without opening it for editing first does nothing to change the original definition of the component.

Box types faster.

1 Like

Thanks for the reply but unfortunately, that solution doesn’t change any

@ Box, just to make sure, I repeated the setup with out turning the cube in
to a component.

  1. Create a new skp file.
  2. Create a rectangle 1m;1m.
  3. Use the P/P tool and pull the surface up 1m.
  4. Select the entire cube (but don’t convert it to a component or group).
  5. To scale it I tried two ways:
  6. use the tape measure, select one edge and type 10mm, or
    2. use the scale tool and type in 0,01
  7. Save the model.

When you import it in to another skp file each side of the cube is still 1m.

Can you try theses steps?

Thanks again for your help

I have to ask are you sure the cube is being scaled? Are you hitting enter after typing your scale ratio. I assume you are using a system that uses , as the decimal point. If not you need to type 0.01 Or after typing 10mm enter, does it ask if you want to resize the model?
Following your steps I get this.

Cannot duplicate your failure;
First part of 6 you should get question box has been asking about;
On second part using the scale tool you have to scale all three axis and you should see option in left corner of screen??

The proper way to use the Tape Measure tool is not to “select one edge” but to click on both endpoints of the edge. Maybe this is where your process is failing.

Thanks for the responses.

Just a bit of background, I am a long time user of SU so I do have a bit of
background using this tool :slight_smile:

@ Dave, thanks for the comment but, “select an edge” was not literal. You
can’t select anything with the tape tool. I just meant I picked corner to
corner on one edge (not diagonal).

It could be the fixes suggested by mac1 and box were correct after, but I
did something strange. ??? Don’t know. anyhow we can end this now. Thanks
again for your efforts.