Scale vs. Modified Scene


#1

Hello,
I am having another small problem that has never happened before until late last week and again today. I have a SU model with several scenes saved. I have a Layout file that is ready to accept the SU Model. I insert the SU model into the Layout file as I have done for several years without a problem. Today, though, when I navigate to the scene I want it opens the viewport fine and the scene is there, but the scale is not set. When I hit “ortho” to set the scale, the scene immediately turns to “modified”. I can then set the scale. When I go back in to the actual scene I want, the “modified” goes away and so does the “ortho” and the scene is not longer to scale. I had a similar problem last week when I could not “duplicate” a viewport because the scene was “modified” and I did not see it. But now, I cannot set the scale of the viewport.
What could I possibly be doing wrong? I have been working with Layout for years and this is my first real experience with "modified’ scenes.


#2

UPDATE:
Turns out that the problem persists with only one scene - the first scene I made. All the others function properly.


#3

Is the problem scene using Perspective instead of Parallel Projection? In that case you should make the switch in SketchUp and update the scene. Also check that the scene properties are set to save all the necessary features. One of the basic SketchUp templates has almost all the scene “Properties to save” disabled by default.

Anssi


#4

It sounds to me that you are creating the problem by changing to Ortho in LO which makes the scene show as modified. Don’t make changes like that or open the viewport to change camera position/zoom. Never let the scene become “modified”. Make any changes needed to the scene in SketchUp, update the scene and save the file. Then update the reference in LayOut.


#5

ANSSI: The scene is Parallel Projection, the same as the other fifteen scenes that are loading correctly. All the scene properties have been saved as always. I am using the same template that I always use.

DAVE R:
I have never changed to Ortho in LO until today because the scene is not coming into LO with the scale set properly. It is not a workflow problem: I do not open the viewport in LO nor do I ever “let” the scene become modified. This is all happening to the first scene for the first time in my experience, today. I have been, as a routine, making the changes in SU and the update in LO. But today, for some reason, the results are not the same.


#6

Could you share the LO file? By private message if you don’t want to make it public.


#7

I have nothing to help solve the problem, but I have experience exactly this issue before. I have found that erasing the viewport and re-inserting a blank viewport solves the issue for me, but I don’t know why it would.


#8

Uploading…


#9

Looks like it might be too big. I sent you a PM.


#10

I have been struggling with this periodically still. There just seems to be times when Layout will not let me set a viewport to a specific scale without “modifying the scene.” I assume I am doing something to create the problem, but I can’t figure it out.