Save crashes display driver and hangs program

I recently installed SketchUp Make 2015, and if I try to save with some templates, notably the two basic ones, my display driver crashes and recovers, leaving SketchUp in a blank window, not responding. I can, however, save from the architectural templates, and can save from any template in SketchUp 8. I am not having any other problems with the program until I try to save something,

I am using WIndows 8.1 with an AMD FirePro V4900 with the latest dirvers. I can still use the program as long as I start from a “Good” template, but why should some be “Bad”?

AMD drivers have a history of OpenGL deficiencies - OpenGL function calls that SU requires are left out of the driver. So the latest driver may not be the best.

SU15 uses Ruby 2.0 while SU 8 uses Ruby 1.8. Also each new version of SU increasingly rely on OpenGL functions that previous versions may not have used. Saving files is one example.

Have you tried disabling hardware acceleration inside SU through Window > Preferences > OpenGL then save?

Do you use any non-English characters in your Google account name or with your computer file system?

Do you use the latest SU Make 2015 version 15.3.33# form last Thursday?

Thank you for the responses. Disabling hardware acceleration worked. As I said, though, I am able to save if I start from one of the “Architectural” templates with acceleration enabled. I wonder why these are “Good”. I notice that these two are larger than the others.

Disabling hardware acceleration confirms that your driver isn’t 100% OpenGL compliant as disabling hardware acceleration means the GPU isn’t being used, all the work is being done by the CPU. OpenGL is composed of about 300 function calls. All too often, driver developers leave out some function calls that most of their consumers don’t need in the programs they use. AMD has a reputation for doing just that. However, SU will not work properly with the missing function calls.

Solution: try older drivers and/or keep installing the latest driver in hopes the deficiency has been addressed.

To further isolate the problem, sending in a bugsplat would be useful, but you indicate that doesn’t happen. So as templates are just SKP files with a bunch of preset modeling preferences, start with a basic template and systematically change the preferences to match the settings in the architectural template. And try saving the SU file with each change.

Or just don’t use the basic template.

I don’t want to roll back the driver, since the latest one fixed a different issue. Maybe I’ll try posting about this on the AMD forum.

I was trying to see what the differences between the various templates are by viewing them in various editors. In a hex editor I see that there’s a lot of character-null-character-null type strings, regular text, and what I assume is numeric data. I see references to the color of the ground plane and units of measurements, but see no way of setting these via the menu. [EDIT: OK, I see where you can set the units] Would I need the Pro version to do that? I’m using Make,but I can’t justify the cost of a Pro license at this time.

I certainly can use the “Good” templates, but I would like to learn about how to use the program more thoroughly.

You can set all sorts of stuff - units, text, dimension text, Scenes with different camera camera positions, preset Layers, etc. Explore the Style browser for background, line appearance, wallpaper, etc. Open it from the Window menu.

Thanks! One of the biggest hurdles in learning software is often just finding where everything is.

I should also mention you can save your own templates from File > Save as Template. Purge unused styles, materials, geometry from Window > Model Info > Statistics before saving though so the Template doesn’t collect a bunch of unnecessary clutter.

And do test saves to check if you crash along the way. You can have a second instance of SU open with duplicate style setting for a record and try saving the first instance to check for crashing issues.

Some success - I found that if I open in one of the Simple templates, and check View > Edge Style > Depth Cue, I can save just fine. But the Architectural templates don’t have it checked, and I can save from those.

I also found that if I open the Styles Browser, and select the Simple style (which I’ve not altered yet; it still has Depth Cue unchecked), this also crashes the display driver. This is true of some of the other styles as well, but again, if I check Depth Cue, they seem to be OK.

As long as I can use the program, I am reasonably happy.

@ChrisFullmer would someone be interested in this AMD driver crash?

I have exactly the same issue. The solution to use an architectural template to get into SKUP & turn off graphics acceleration worked, but is not ideal.

Has anyone had any luck with AMD about this issue or any suggestions about older drivers to use? Or older versions of SU (ugh)?

I have this situation too, and I’m really irritated as I have just bought a brand new machine with an AMD Firepro V3900… and since I can’t actually use the GPU it’s no better than the 8 year old machine I was using before.

I can confirm that checking the Depth Cue option solved my crash!

if you would have checked the forum against the AMD FirePro before buying at least I would have dissuaed you from buying it… if not required for other applications drop/sell it and buy you a working nVidia GeForce GTX 960 (or better)… Asus Strix or MSI TwinFrozr versions are fine.

Sometimes the SU team contacts the driver developer about issues like this. The OP did do a nice job isolating the problem which seemed to have only popped up a few months ago. @AlexB, who’s the best person to ping on SU team if this is something to be addressed?

@catamountain I am checking into it - thanks!

Same problem here :frowning:

Have asked for support from AMD, had a reply off-forum. They sent me a beta driver to try but this hasn’t improved matters.


@rosenthaller, bless your heart for working with AMD on their beta. Keep it up and report back with constructive input to AMD. They need someone like you to test the beta drivers. It will eventually work, but the developers are writing code that’s suppose to work for a lot of things - not just using SU - so they need your input.

1 Like