AMD GPU Crash on export or save

Windows 10 64 bit.

AMD ATI FirePro V4900 (FireGL V) Graphics Adapter

Intel i5 3.4Ghz 8gb RAM

Hi, I am running Sketchup Pro 2014 and 2015. When I turn Hardware Acceleration on within Sketchup the screen goes all jittery and half black, the program freezes and I get an error message:

“Display driver has stopped responding and has recovered.”

The whole reason I purchased this GPU was to improve sketchup performance and saw literature saying that Firepro V was a workstation GPU.

Can anyone recommend an alternative GPU that is similar spec and definitely works?

The response I’m getting from AMD is “Sketchup’s problem”.


this is not a SU problem but caused by the lame OpenGL support of the Windows drivers…

…therefore all people requesting here before buying are constantly emphasized to neither buying AMD nor specialized CAD graphics accelerators… at least for SU.

The AMD FirePro V4900 is a low-end legacy product,go for a nVidia GeForce GTX 960/970/980 but check that your PSU is capable to support the wattage required especially with the big ones.

Thanks, I’ll look in to these.

g3Force GTX 960 is incompatible with my motherboard from what I can see.

670/980 are out of my budget.

Is there any good reason to avoid AMD W5000? This is listed as certified tested with sketchup and Win 10 on the AMD website.


Using this site I’m told that the NVIDEA GTX 960 is not compatible with my h81H3 motherboard, however other brands of GTX 960 are.

As a novice this is very confusing to me.

Can anyone recommend an alternative manufacturer of GTX 960? MSI? EVGA?

Better still an actual model?

Appreciate the help.

nVidia is the maker of the GPU, GeForce GTX the series of the GPU.

MSI or Asus are fine, If your case does have limited space go for the Asus Strix (or the Gigabyte GV-N960OC), all of them with silent twin fans. PSU should roughly provide 350-400 W for running them without being at the edge.

Back to the V4900 incompatibility issue, I’ve jus heard back sfrom AMD that the V4900 has been tested with sketchup successfully with Win 8.1 so they’re thinking it’s something to do with Win 10. Does this make any sense?

1 Like

Were you able to solve the problem. I have V4900 on two of my systems and I am facing the issue on one PC right now.
My Display driver crashes only when trying to save that file.

SU uses OpenGL when saving for the last few versions of SU. So if the latest graphic driver doesn’t help you can try disabling hardware acceleration from inside SU at Window > Preferences > OpenGL when needing to save. Try it, if at least as a test of the driver involvement.

Another thing to try is installing the 32-bit version of SU instead of the 64-bit version.

Another strange problem with some AMD cards involved the choice of SU line style…

Hi, I ended up buying a GE Force GTX card and have had no problems with this. Seems to run great with all my other programs too.

Good luck…

The problem is not a professional graphic applications. Are your drivers !. Graphics cards are designed for stability and reliability. In the case of sketchup 2015-2016, the problem is solved by installing the oldest drivers and automatically updating bloquenado “WindowsUpdate”.
All this happens at Open Gl version of the application and the driver.

Sometimes the newer drivers, are not usually the best.
In the case of V4900 Firepro
The version of the FIRE GL-13.152.4 driver is WHQL-x32x64-163380


I have a similar problem with Sketchup Make 2015 after upgrading to Win10 recently. This thread has already answered a lot of my questions. My info,

ATI FirePro V4800 (FireGL)
AMD Radeon
4850 MB

running under Win7 this ran fine, but running under Win10 Sketchup crashes back to the desktop if I try to save with hardware acceleration enabled. If I disable hardware acceleration the problem disappears, but others pop up (distinct and annoying “lag”, for example). The graphics card is from an old dedicated CAD workstation and my computer is, admittedly, probably due for replacement soon as it’s well up into the 6-8 years old category.

Our IT guy and I found an updated driver from AMD, but this did not solve the problem. I’ll continue working on the problem while reading through the rest of the responses here.


There’s nothing to work on besides swapping to a capable nVidia GeForce GT(X)… at least if you wanna work reliably with the system.

Recently many people with AMD graphics cards have found that switching to the 32-bit version of SketchUp has helped.


One work around I found that works is as follows,

  1. When you’re ready to save your model, go to Windows->Preferences,
  2. Click off Hardware Acceleration,
  3. Save your model (you do not have to exit and return to Sketchup during this step),
  4. Go to Windows->Preferences and switch Hardware Acceleration back on,
  5. Continue working.

This solves the crash problem and also solves the “lag” problem in Sketchup when not using hardware acceleration.