Sandbox toolbars won't appear - Sketchup2020

I found three different posts here about Sandbox not working.

  1. I tried “repair” installation “Run as Administrator” as suggested
  2. I have the “Sandbox Tools” extension enabled in Extension Manager
    …but when I check on the “Sandbox tools” in the list under View->Toolbars->Sandbox Tools, nothing happens (no toolbar appears).

Can anyone help me fix this?

The toolbar is likely opening off screen. Try going to Window>Preferences>Workspace and clicking Reset Workspace.

DaveR-

Thanks for this suggestion. Unfortunately, it makes no difference

Try repairing the installation of SketchUp. Close all instances of SketchUp and LayOut. Find the downloaded installer file, right click on it and choose Run as administrator. If presented with the option, choose Repair. After it has finished, shut the computer down to do a cold reboot. Then check to see if you can get the Sandbox Tools toolbar to display.

If that doesn’t work we’ll dig in even further.

Okay. I repeated the “run as administrator” repair fix, then shutdown my computer, waited a minute or so, then powered the CPU on. I don’t have any change in the situation.

What happens if you uncheck the toolbar, close SketchUp, open it again and activate the toolbar?

Nothing different. Virtually all the toolbars in the list give an immediate visual change to checking/unchecking the box next to it (without exiting and re-opening the program). “Sandbox” does nothing.

Have you used an external monitor?

1 Like

I don’t know what this means. I have three display monitors attached to my CPU. I only use one for Sketchup drawings.

image001.jpg

Is the toolbar on one of the other displays?

Uh, no. The “reset workspace” exercise was supposed to remove this possibility, I thought.

Sandbox is an extension. If an extension earlier in the alphabet runs into trouble, Sandbox, and later alphabet extensions, may not load.

If you close SketchUp, then go into this folder (copy and paste this text into the path field of File Explorer):

%AppData%\SketchUp\SketchUp 2020\SketchUp

Temporarily rename Plugins to something else. Now open SketchUp and see if Sandbox is there. If it is, one of your other extensions may have problems. You could look in the renamed Plugins folder, think about what might be a problem, then close SketchUp, move some extensions back into the newly created Plugins folder, and open SketchUp again. Hopefully you will soon track down the plugin causing the problem.

Working with Keith in a PM string. Turned out deleting both Private and Shared json files and restarting SketchUp solved the problem.

I tried this but didn’t have success - what’s the process bc i still can’t get my sandbox toolbar up in 2021. it’s not even an option for selection.

Do you have Sandbox tools enabled in the Extension Manager?

When you installed SU2021 did you do so correctly by right clicking on the downloaded installer and selecting Run as administrator?

It is not in the manager. And I’m assuming yes it was run as Admin. Our IT department has to enter credentials any time we install software on our laptops. I’ve tried to add the extension itself through the manager, but it gives me an error every time.

The Run as admin thing at installation needs to be done under the user’s login, not a system admin’s account.

so is your recommendation to do a fresh install?

My recommendation is to start with a repair of the installation under your user login. If your IT department will grant you temporary admin rights to install software on your computer download the SketchUp installer, right click on it and choose Run as administrator. Then choose the Repair option if it is presented. Doing this should not affect any 3rd party extensions you may have installed, your workspace arrangement, or other preferences.

Prior to my retirement, my employer had a similar arrangement designed to prevent the average user from having admin rights but I could request temporary rights which allowed me to properly install applications like SketchUp as well as test software I needed for servicing anesthesia and respiratory equipment.

Very helpful - thanks so much!