Same image for Diffuse map and displacement map or bumpmap in Vray

So , I applied an image to a rectangle using Import option under the File tab , so that i can scale the image to the size i want. Now, sketchup creates a material automatically with that image as a diffuse image. I want to apply the same image for displacement map. The only way i assume i can do it, is by clicking the displacement map icon under the created material and add the same image… But now the displacement map gets applied in a different scale…

Question : Is there any way i can use the already scaled image map for displacement or bump maps ?
If i want to scale the image once and use multiple times in same material or in multiple material , what is the best way to do it?

or i have to scale every single time ?

Note: In 3dsMax you just create a bitmap of desired scale and the same image can be used in different maps { displacement or bump } or you can even use in different material.

Image 1: image applied and scaled in the size i want

Image 2 : after adding displacement map

image 3 : after removing the diffuse map

As u can see the displacement map got applied in different size, that is why the output is clumpsy

What renderer are you using…?

Thanks for the quick response :slight_smile: . Sorry i forgot to mention its Vray renderer .

I use the same texture image for bump map sometimes when I render in Kerkythea. I used the oak texture I applied to these stools in SU as the bump map in KT. It’s not obvious in the unpainted version but you can see it in the black version.

The image is pulled out of the tx folder created by SU2KT.

By the way, Vray isn’t included with SketchUp.

1 Like

I’ve been using the same texture image for bumps maps for a while now , until this scenario where i had to apply bricks texture. so i scaled the image that it will match the real world size. But faced trouble after applying it for bump map… How do i solve this?

Yeah, I was gonna say if it came along with sketchup as @Deepak said, I probably didn’t have to cut my lunch money to pay for my copy.

Anyways, scaling texture is completely fine even for bump or displacement map. I don’t know if older versions don’t play nice but, mine doesn’t do that.


Image used


Normal


Bump


Displacement

Are you using two different size images for the diffuse and bump? that might be your problem.

I assume you applied material using method 1 ,
if yes , then yea there wont be any trouble as same image is used , same size…

but i applied the diffuse map using Import option under File menu using method 2
now it allows me to scale as i wish by clicking and dragging… but i cant do the same for displacement map.

I am not sure why you have to stick to Method 2.

Even for just SketchUp, importing as an image as supposed to a texture has some caveats such as not being able to tile or wrap an object.

I do not know the methods in 3DMAX, but importing as an image and tweaking vray material settings is probably not a correct method.

https://help.sketchup.com/en/article/3000114

I’ll explain why i was keen in method 2. Please help me with a solution.

Lets say the below 3 x 3 tile is 3 feet x 3 feet { 1 tile = 1 feet } which i want to fit to side of a rectangle 3 feet x 6 feet…
So basically i want the image to tile only 2 time on the 6 feet legth …

using method 2 i just drag and scale the image and i get the output what i want.

but i follow method 1 the image just tiles so many … whats the solution . ??
how do i control the tiling on dimension that i want ??

That’s not much of an explanation. Why don’t you set the material size in SketchUp to be 3’ x3’ in the first place?

When I create textures for SketchUp I create them at the desired size from the beginning. That way there’s no need to drag the scale of the texture.

It just seems to me you’re making it hard on yourself when you don’t need to.

1 Like

It is because your image size isn’t set to 3’ x 3’. Make sure as you bring in the texture, your texture is set to 3’ x 3’.

My model is using metric, The texture is 150mm X 150mm and the rectangle is 300mm x 300mm Therefore it repeats once for both green and red axis.

And as you increase the size of the geometry, increasing 300mm on one side, you get what is below.
You MUST NOT scale, you either move or push-pull. Scaling is stretching.

1 Like

Thank you both for continuous support … Am sorry , I think am just bad at presenting my question. Actually am not able to find the solution. YES i just tried setting the material size too. The diffuse image seems to scale properly in the size that we mention in the material size… But my whole problem is when i use the same image for displacement. Am not able to set the size for the displacement map…

Where do i mention 3’ x 3’ for the displacement map ??

You don’t have to set the size for the displacement map. It respects the re-sizing that the diffuse map has. In fact, if you tweak it in anyway, there is your problem.
For that reason, you have to use the same size image (pixel/resolution) for the displacement.

Finally… Resolved
Thank you both … YES setting the size in material also sets the size for displacement map… Also when i reposition the diffuse image the displacement maps also repositions accordingly. But if i remove the diffuse image the size of displacement image chages again. Thats is why i was getting confused till now.

Anyways My issue is resolved now.

Image 1 : my material size set 3’ x 3’

image 2 : TexBitmap of diffuse, you can see i’ve used tile.jpg

image 3 : TexBitmap of displacement , you can see i’ve used the same tile.jpg

image 4 : render output , displacement also have been adjust to 3’ x 3’

image 5 : i removed the diffuse map , but now displacement maps is not 3’ x 3’ …

wait, why are you removing diffuse map?

SketchUp’s default material translates into diffuse map. Therefore, removing diffuse map, you are forcing SketchUp material to respond to Vray material. (which can create a lot of problem as what you are experiencing)

If you want another type of image, change from the sketchup side. Either from material editor, or better yet, create a new material.

Because you would normally you would work in this sequence:

Create geometry
Apply SketchUp material, adjust texture if necessary.
Adjusted texture translates into Vray material (this is done automatically if you have Vray loaded)
Apply additional values and mapping such as (reflection, bump, displacement)
Render
Happy client :grinning:

1 Like

Kudos !!! i dint know removing diffuse map it will respond in weird way. Thanks for the Heads-up and explaining the process. Now i understood :+1:

1 Like

Great.

Glad I can help :smiley: