Vray displacement shows in preview but not in VRFB


I am using Sketchup Pro 2020 and Vray Next (still in trial period), and I am trying to get displacement to work correctly, specifically to create a lap siding material.

To experiment with this and other features, I simply started a new model with a couple boxes extruded. I made one box a component and the other I left a stand alone object.

To create this material, I have tried using a default wood plank material and also a generic material with a simple diffuse color. I then configured a gradient black to white texture, rotated the texture placement to horizontal and set the repeat value to 6 (to match the wood planks bitmap). I then added a displacement attribute, and slotted the gradient texture to it.

The problem I am having is the preview pane (wall close-up) shows the displacement correctly (albeit with some distortions in the corner edge), however it renders flat in the VRFB. I have tried applying the texture to just the component, then to all faces inside the component. I have tried reversing faces with no luck. Also tried increasing the amount, using 2d displacement, and normal displacement. The displacement switches in the material and settings are both on.

Any ideas?

I am not sure but it might be that you must use CPU rendering. There are some things that CUDA/RTX dendering modes don’t support.

That was it! That’s strange, and will take my renders a lot longer, bummer.

Thanks for your help!

I understand that a displacement map creates new actual geometry so it is slow and requires CPU action. A bump map would be faster, but of course its effect doesn’t look so realistic in corners, for instance.

I see. I may try using a bump map again. I am new at rendering and at first pass, the bump maps just didn’t get the realism I was looking for. But not sure it’s worth the additional render time.

Also, just trying to nail down the displacement attribute, the displacement didn’t match the wood plank bitmap like it does in the preview, there were way too many “laps”. I tried adjusting the texture placement back down to one, but its still showing about 3 laps per plank. I adjusted the material size in SketchUp to reflect the Vray material (100cm), does the texture map in Vray not follow the SketchUp bitmap size?

I think I figured it out (sort of). I reduced the ‘repeat UV’ to less than one to adjust size. It was too difficult to match perfectly to the wood planks texture’s lines, but realized there was no need for a ‘plank’ texture since the displacement will create the shadow lines.