Runtime Error! when closing SketchUp

error
runtime

#1

I open SketchUp Pro 2018 and literally only close the application (i.e. no drawing in the application), and I get a Microsoft Visual C++ Runtime Library Error. Any changes made within SketchUp, like toolbar placements, application window size adjustments, or shortcuts made, are lost.

“Runtime Error!
Program: C:\Program Files\SketchUp\SketchUp 2018\SketchUp.exe This application has requested the Runtime to terminate it in an unusual way.”

Using Windows 10 Pro… I have had this issue before on Windows 7 Pro & tried every single thing I could, and every update I could, but never found a solution.


#2

Is it on the same or different machines you have seen the error in both Win 7 and Win 10? Does it happen every single time you close SketchUp? What plugins are installed?


#3

Same Machine with different fresh Windows installations. It happens every time sketchup closes.

List of Plugins…
1001bit_pro.rb
1001shadows.rb
Abvent_Renderin3.rb
ae_TextureResizer.rb
ae_ToolbarEditor.rb
ae_WireTool.rb
ams_ClothWorks.rb
ams_SoftenEdges.rb
bezierspline.rb
CB_Cline.rb
CB_Rot90.rb
clf_shape_bender.rb
compoSprayToolbar.rb
compoSpray_142.pdf
DBUR_LayerManager.rb
DM_ProfileBuilder2.rb
Elev45shadows.rb
ene_camMemory.rb
ene_relative_top.rb
ene_texturepositioning.rb
ene_uprightExtruder.rb
extrudelinetool-Modified-TIG.rb
faceFlattener019.rb
Fredo6_!LibFredo6.rb
Fredo6_Curviloft.rb
Fredo6_FredoScale.rb
Fredo6_FredoTools.rb
Fredo6_JointPushPull.rb
Fredo6_RoundCorner.rb
Fredo6_ToolsOnSurface.rb
Fredo6_TopoShaper.rb
Fredo6_VisuHole.rb
lumion.rb
Multiple Offsets.rb
PurgeAll.rb
PutOnLayer_sortname.rb
RamTools_StepEx.rb
RND_Canvas.rb
rp_superellipse.rbs
Skalp.rbz
Skalp_Skalp.rb
sketchrope_ropefall.rb
SketchUcation.rb
skin.rb
skp_keygen.rbs
smustard_DropGC.rb
smustard_PathCopy.rb
smustard_Weld.rb
SoapSkinBubble.rb
SplitUp.rb
su_advancedcameratools.rb
su_dynamiccomponents.rb
su_sandbox.rb
su_trimble_connect.rb
TIG-splitdonut.rb
TIG-splitsausage.rb
TIG-splitTOOLS.rb
tt_architect_tools.rb
tt_axes.rb
tt_cleanup.rb
TT_Lib2.rb
tt_material_tools.rb
tt_selection_toys.rb
tt_text_editor.rb


#4

This could be related to an extension using C code, e.g. a renderer. Have you tried running SketchUp with no plugins?


#5

Genius… Tried with removing Render[IN] which TBH… I don’t really use anymore, and that solved that issue.
Thanks Eneroth, appreciate your suggestion.

Also… I see it’s not listed above, sorry.

If you have any insight into this, I’d appreciate it


#6

Go to Settings> Apps> scroll down until you find the visual C packages, click in each one, if you see a modify button , click on it. Choose repair . If that doesn’t help you will probably have to reinstall Windoze.


#7

Eneroth’s suggestion worked though, and the Render[in] plugin I have is possibly old, as I don’t use it very often at all.

Quite happy to just remove it for now.