Running 2021 and have 2020 installed. Need to Re-install 2020

I’m sure this has been dealt with previously but sometimes it’s difficult to find the information again.

Recently tried to un-install SketchUp 2020 Checkup but it was reporting a missing file. Managed to download the installation file and was then able uninstall it.

Now my licensed SketchUp 2020 won’t open - I get “The code execution cannot proceed because SketchUpCommonPreferences.dll was not found”

So if I try to repair the 2020 installation I run into the missing SketchUpPro.msi problem that has previously been reported.

I have a licensed 2021 installation - if I uninstall 2020 to re-install it again will it be licensed still?

You could do a repair without uninstalling, download a new copy of 2020 and right click and choose Run as admin, then repair.

Thanks for the reply Box.

Downloaded the 2020 installation file again > right click > run as admin and… it comes up with the missing .msi file again

I’m pretty sure you will be ok if you uninstall it, if not I’m sure @colin can sort the license.

1 Like

Your ‘active’ license is 2021, so you would be able to (re)move that activation to other machines.
Older version activation can still be (re)activated on machines where it was once installed provided that:
The Mac address hasn’t changed. (Typically, the LAN adapter on the motherboard) and the same username is used.

Upon activating ‘classic’ licenses, this info is stored on the servers and a sketchup.lic file is placed in the users AppData.
Repairing installations doesn’t replace those, so it should work.

1 Like

I think Mike is correct, and the existing 2020 license should be picked up.

There were versions of 2020 that had an issue where uninstalling the viewer could lead to issues with the SketchUp installer. You could make sure you are on 2020.2 by getting the installer from this link:

https://www.sketchup.com/sketchup/2020/SketchUpPro-exe

Worse case, reinstall the viewer.

Thanks Colin, 2020 up and running

Just to report that re-installing 2020 messed with 2021 being the default program.

I tried to re-associate 2021 with my files by way of “open with>choose another app>always use this app” but 2021 was not in the list so I had to browse for it. This did not work either. However…

Curiously 2017 with the new blue logo was listed!

So I clicked on that and viola! all my files are opening in 2021.

BTW I tried to do a repair of 2021 and I got “the feature you are trying to use is on a network resource that is unavailable”. It wants SketchUpPro.msi

EDIT: Screenshot shows Layout 2021 because I took the screenshot after I had first clicked on 2017 with the blue logo

Use the run as admin/repair option on the install.exe should reset it as the default.

Just edited my post to say that the SketchUpPro.msi error occurs when trying to repair

Something odd somewhere then.

There is an ongoing issue where the Open With sub menu shows repeats of one version of SketchUp or LayOut, instead of the different versions. That still hasn’t been fixed yet, but the initial menu has been fixed. So, use these menu items:

image

and don’t use the Open With sub menu.