Ruby console plug in problem


#1

i just disabled ruby console as i was witnessing an error with it but when i re started my computer i found that all the extension were uninstalled even i found my self longed out from sketch up extension warehouse even i can not login in it
but i can log in in extension warehouse using google chrome.

this is what i typed to disable ruby console

To install a SketchUp Ruby plugin script with the .rbz format:
We recommend logging into your computer as an admin before installing any Ruby scripts. …
Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). …
Click on Extensions. …
Click on the Install Extension button.

after doing above process now i am facing a problem that i can not find my v ray plugin or any plugin in my sketchup software even i tried to re install v ray but after re installing even i can not find it in my sketchup


#2

I am not aware that you can disable the ruby console. It is hard-coded in the menu on every version of SketchUp.

You probably disabled that Ruby (which is loaded) automatically loads plugins:
https://help.sketchup.com/de/article/1700320

Sketchup.plugins_disabled = true

This is saved as a preference, so every time SketchUp is restarted plugins will not be loaded on startup.

Without plugins being loaded, plugins like V-Ray will be missing. After re-enabling loading of plugins and restarting SketchUp, it should appear again:

Sketchup.plugins_disabled = false

This is mentioned at the bottom of the article. Does this resolve the issue?


#3

Like @Aerilius I’m a bit confused by your post. The standard Ruby Console Window is not generated by a Ruby file, it is compiled code. Turning off or disabling Ruby extensions should not affect it. Do you mean that you were using an alternative console provided by an extension and tried to disable it? You can disable individual extensions using either the Extension Manager window or the sketchUcation extensions manager. Completely disabling plugins is overkill if there is just one causing problems.


#4

unless the OP turned off Ruby with the command line switch…

that blocks Ruby Console from loading as well…

john


#5

thank you guys i enableed it again but still it shows this msg
thats y i tried to disabling it

main thing is i have tried couple of times re installing sketchup even i am not able to solve this problem
i have attached the screen shot which includes the error

as we have started this discussion then i would like to share problem which i am facing when i start final rendering my computer gets restart every time it is being headace from last 20 days i have re installed sketch up and all plugins atleast 10-15 times but every time i am facing same problem----------my computer is to much capable to handle rendering even i am facing the problem

my computers confugration is 32 gb ram intel i7 and system is Ashus made and 8 gb graphics card

i am attaching the screen shoot of this prob too which makes my computer restarting while final rendering


#6

So if it still happens after reinstalling SketchUp and extensions, maybe reinstalling just is not the way to solve this problem?
Did you ever manually change anything in the folder %Appdata%/roaming/SketchUp/SketchUp 2017/SketchUp/Plugins, and when you reinstalled, you installed through Extension Warehouse?
Have you thought about checking whether this problem was solved after reinstalling SketchUp but before adding any plugin or script (ensuring there is nothing left in the plugins folder)? Only when the empty installation is without issues, add the plugins one by one back.

Besides that, the error message clearly says it occured in tt_vertex and DBUR_ScenesTool (?) and you should contact the author (Thomthom). Although I suspect another script redefined something in Ruby core.


#7

Andreas, he’s running SketchUp 2014, and it looks like quite a new version of Windows,
perhaps a version that SU2014 is not meant to run on ?


@himalaysoni, please give better details in your forum profile.
What model of Nvidia graphics ?
What version of Windows ?
What version of SketchUp (Help > About):


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.