[FR] ONLY load extensions from the users personal folder

Right now I cannot start SketchUp at all at my university. A load error in V-Ray (which I am not even planning to use today) causes SketchUp to bugsplat. I can’t even get to the point where I can open the Ruby Console and disable plugin loading or open the Extension manager and disable V-Ray.

Uninstalling the plugin is impossible too as it is installed to ‘C:\ProgramData\SketchUp\SketchUp 2018\SketchUp\Plugins’ where I don’t have write permission. Instead I have to wait for the system administrators to fix the error which perhaps takes days.

Please make it so SketchUp doesn’t load Ruby plugins from any folder except the personal plugin folder. The plugins can very well be installed in a shared folder, but the loader script must be within the users grasp.

sketchup.exe -DisableRubyAPI

That is the whole point of installing extensions there. They are maintained by IT.


There needs to be better load control and error trapping without doubt, but I don’t think this is the answer.

I would rather a standalone configuration utility that allows for plugin / extension settings changes outside SketchUp (while it is closed.) POSH GmbH may actually have such a utility.

@SketchUp3D_de ?

Starting the API doesn’t do much good as you can’t access the extension manager and disable the faulty extension without it. Using SketchUp without extensions is like using an OS with no programs installed.

I think the end user should always be able to override the extension installed by IT. At my uni IT used to have quite a few really shitty extensions installed that were forced onto all users. We talk extensions not playing nicely with the undo stack, global variables and the like. Luckily those are now gone, but I don’t think SketchUp should allow for things like that to be forced onto the users.

Can you edit the JSON file to switch off Vray?

I think so, but before I tried it SketchUp suddenly started loading correctly again. Maybe IT fixed the issue.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.